RStudio 1.2.1578 for Ubuntu 14 dependency issue

Same problem to topic Preview 1.2.747 doesn't install in Ubuntu 16.04 , closed but still not resolved.

I attempted to install and got the message that the libclang-dev required package is not installed.

There is no package with that literal name available to apt-get but there is a libclang-3.9-dev and I installed it along with libclang-3.9 and libclang-common-3.9-dev. Still same error message, it seems to insist on libclang-dev. I tried installing libclang-3.5-dev with the same outcome.

The install did replace my rstudio but the font on all UI elements was tiny and none of them responded to mouse clicks. Don't know if it was related to missing dependency or separate problem.

After doing sudo apt --fix-broken install I tried sudo dpkg --ignore-depends=libclang-dev --install rstudio-1.2.1578-amd64.deb and this went to completion but apt-get continued to report the rstudio package as broken and I continued to have a non-usable UI as above. I also tried using equivs-control and equivs-build from the equivs package to create a dummy package that provides libclang-dev. After another fix-broken, I again installed the rstudio package, this time without --ignore-depends and that too seemed to complete its installation. However, I still had an unusable UI.

What are the official instructions for deploying RStudio 1.2.1578 to Ubuntu Linux 14.04?


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.