Rstudio 1.2.1572 not recognizing UNC addresses

I was previously using RStudio 1.2.1565 and 1.2.1568 with no issue (R 3.6.1, Win 10 x64, git 2.23.0). Running projects on a remote drive with a git repo already established worked fine. Running Shiny apps also worked fine. When looking in the terminal, the remote path was correct (with an assigned mapped drive letter).

After upgrading to 1.2.1572 there seems to be an issue related to UNC addresses. Starting the same project on a remote drive, there is no git connection. The git tab is missing, and in the terminal it fell back to a local drive (C:\) with an error message.

CMD.EXE was started at the above path as the current directory, UNC paths are not supported. Defaulting to windows directory.

This is also reflected when attempting to run the project's shiny app. Under the former 2 releases, running the shiny app would use "shiny::runApp()", whereas the most recent release attempts with "shiny::runApp('')" and finds nothing. Manually running it with the full path within quotes works, "shiny::runApp('\\foo\bar\biz')" as well as running it as "shiny::runApp()".

Copying the project folder to a local folder does not result in these issues.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.