rstudio 1.2.1335 unable to launch in windows 10

I have installed R3.6.1 and rstudio 1.2.1335 in windows 10
however i am not able to launch rstudio
the main window appears with the tool bar only, a circle keeps spinning and nothing happen for a long long time.
I check in forums eg. stackover flow and this community. I tried all suggestions and recommendations I found but still no luck.
I have seen in the internet a lot of people facing this problem but no solution. can someone please help .
Thanks :grinning:

Do you see the same problem with the current latest release of RStudio (v1.2.5001)?

The more information you can provide, the better the chance of getting to the bottom of this problem. Can you try running a diagnostics report, as described here?

The best way to share the results is usually to upload it somewhere else (Google Drive, GitHub gist, Dropbox, etc) and link to it here.

yes, i uninstalled r3.6.1 rstudio 1.2.1335, annaconda 3.
reboot, reinstall annaconda3, r3.6.1 and finally rstudio 1.2.5001.
when I run rstudio, just a blank window with toobar .
i cannot run the diagnostics because when i press the help button and other buttons, no responses at all

Thanks for the info!

If you check the link in my last message, it explains how to run a diagnostics report even if RStudio won’t start up. Can you give it a try?

Thank you very much for your advice.

I could not run the diagnostics even though I run
C:\Program Files\RStudio\bin\Run Diagnostics.lnk.
it just hangs!

I could not find the cause of the problem, however, I manage to get rstudio working after going through the following steps.

  1. uninstall R
  2. uninstall rstudio.
  3. use Regedit to delete all entries for rstudio and R
  4. reboot
  5. reinstall r
  6. reinstall rstudio

rstudio 1.2.5001 is work now.
perhaps the problem is some old registry links are not cleared.

Thank you.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.