Rstudio 1.1: A buggy version?

I've found the new Rstudio desktop very unstable. It drives me crazy some of the new features that are behaving bad. Several of them regarding IDE:

  • Glitches when executing Rmarkdown (window flashes)
  • Changing fonts makes IDE to restart completely
  • Can't select code past beyond the Margin Column. Highlighting stops at margin limit.
  • New data viewer column resizing is very picky, going back to previous position randomly even when I'm moving it to right side
  • Using Dark Theme, the green execution progress bar is not visible (even line numbers are barely visible)
  • As average, slower execution than previous version

am I alone on this?


That is kind of wild! I wonder if it is somewhat dependent on the OS? I'm running Sierra on a MBP with Rstudio 1.1.383

For me:

  • Glitches when executing Rmarkdown (window flashes)
    Maybe a little bit of this but not more than I was getting with the last stable release.

  • Changing fonts makes IDE to restart completely
    It reloads the IDE for me but doesn't restart R so no variables are lost

  • Can’t select code past beyond the Margin Column. Highlighting stops at margin limit.
    Can not reproduce

  • New data viewer column resizing is very picky, going back to previous position randomly even when I’m moving it to right side
    I didn't know you could resize these, this is so cool!!! For me, it jumps back to where it previously was if I drift above or below the headers limits. Agreed it's kind of hard to quickly resize these and keep the mouse in that area

  • Using Dark Theme, the green execution progress bar is not visible (even line numbers are barely visible)
    I'm using Rstudio theme: "Modern" Editor Theme: "Monokai" and they work pretty well, might vary by theme (I think Monokai is less aggressively dark than some)

  • As average, slower execution than the previous version
    I started a project with much bigger data than I usually use right after updating and I haven't ever tried benchmarking before so no thoughts on this.

Hopefully, this additional info possibly from another version is helpful. :smile:

Thanks for letting us know. Could you tell us a little more about your environment?

  1. What version of the operating system and version of the os are you using?
  2. What version of R?

The main thing I've noticed is slowness. I have two pain points:

  • Ocasionally when doing "Save As" RStudio freezes for what feels like minutes.
    • Edit: I do not connect to a network drive before someone suggests that.
  • The dataviewer is unusably slow for data with more than about 20 columns.

I'm on Ubuntu 17.04

Windows 10 professional
R version 3.4.1 (2017-06-30) -- "Single Candle"
Dark theme (Ambiance) or White theme. Progress bar is not shown for R scripts
Dark Theme: Data viewer resizing issue (not present in clear theme)
Slowness= reading or writing RDS (previous version was faster)

I can't select files in the file explorer sometimes, when I have two RStudio windows open. Have to restart RStudio to be able to click on a file to open it, such as .Rbuildignore, which I can't open easily in normal file explorer.

Running macOS Sierra 10.12.6 and RStudio version 1.1.383

We have a candidate fix for this in the RStudio daily build (RStudio 1.2) if you're interested:

We'll probably also do a patch release for 1.1 which addresses this and a few other commonly reported issues (waiting to make sure we've found all the glitches!)


I got arrogant and tried to give a 1.2 daily a whirl (1.2.105)…it did not go as planned.

I'm back on 1.1.383 and happy as can be, but just thought I'd let you know in case this was a surprising turn of events.

ERROR r error 4 (R code execution error)
[errormsg=Error in .deparseOpts(control) : could not find function "anyNA"
, code=local(source("/Applications/", local=TRUE,
echo=FALSE, verbose=FALSE, keep.source=FALSE, encoding='UTF-8'))];

LMK if you care, and I'm happy to give you all the system info your respective hearts desire!

1 Like

The biggest complain I have is that I'll often be unable to open any files, either through the window, or by going through File > Open. I'll try all types of files, but nothing happens. Only fix is to restart R Studio.

I'm having the same problem with "Save As" on Ubuntu 16.04.

@mara What version of R are you using? (anyNA was introduced in R 3.1)

3.4.2 (2017-09-28) -- "Short Summer"

I was surprised by that, too!

@mara A mystery! 1.2 definitely isn't ready for daily use yet, so pardon our dust. We'll have a preview up when it is!

No worries. I kinda just wanted to see what would happen!

I agree. 1.1.383 is very buggy and unstable on two of my systems. One is an iMac running Sierra and the other is a 13in MBP running High Sierra with R 3.4.2 on each. Same (un)reliability issues on both: random crashes when switching from console to terminal, when switching file directories, when importing or exporting datasets.

Following @mara I decided to try the new daily build before dropping back to the previous version of RStudio. When I open the daily build, it crashes immediately with the following error output:

Notes: Translocated Process

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib
Referenced from: /Volumes/VOLUME/*/
Reason: image not found

I know dailies aren't ready for daily use yet, but I thought this might help still.

Unhappy/Happy knowing I'm not alone, but hopefully Rstudio Team will address this bugs in short time
Thanks all

I am going to roll back to a previous version because I can't do any development at all. If I build a package, RStudio crashes. If I save a file, half of the time it crashes. :frowning:

Edit: And so does the previous version, and it didn't before. Lovely.

Just like @rdataforge I'm happy to read this - just a as a check on my sanity. I also did the full reinstall of the previous version, and even tried to go back a notch in the R version used (going back to R 3.4.1). I also did the hard reset by renaming the ~/.rstudio-desktop folder, but that was of no use either.

@hendiatris and @FvD, after making sure that all of your files are saved (and ideally backing up your project folder), try renaming the .Rproj.user folder in your project directory that is crashing (assuming that it's a given project that's crashing). RStudio will lose track of which files you had open and any unsaved changes (along with a few other things I believe, but not your actual source files). That seems like the most likely thing to carry over when rolling back to a previous version.

If that fixes it, you can delete the renamed .Rproj.user folder.

Lamentably, that didn't do it for me. Thanks for the help, though