RStudio 1.1.383 in win10 Fall Creators Update seems to make R notebook fail

After upgrade to Win10 Fall Creators Update, in RStudio 1.1.383(or even the latest 1.1.393preview), the Rnotebook seems broken in that, if I click insert button(to insert R, Python, SQL code chunks) it doesn't respond. It also doesn't respond with the "Run -> Run selected lines, etc" Surprising to the left, the "knit" button still works.

This is also R environment indepedent, because I tried both latest Microsoft Open R 3.4.2 and R 3.4.3. Since 1.1.383 is released before Fall Creators Update, I wonder if those buttons losing "response" is due to insufficient testing on the win10 fall creators update platform. 1.1.393 preview doesn't fix it yet.

I tried 2 computers too. Am I the only one here having issues with Rnotebook? Help appreciated, thanks.

Just to have a follow up, since 1.1.383 and 1.1.393preview are both broken, I tried to resort to the daily builds. Daily build 1.2.202 fixed the insert button to insert R,Python, SQL code chunks, but the most important function, "Run -> Run selected lines " is still non-functional under win10 Fall Creators Update x64 OS.

If the developers are still watching, please release a stable build as soon as possible to fix this. How do you expect users to write R code when "Run selected lines" doesn't work?


We haven't been able to reproduce this on the Fall Creators update, and a lot of people use RStudio on Windows 10 so the issue you're seeing is probably more specific. Can you help us by sharing some more details?

Does it happen in a brand new notebook? If it happens only in a specific notebook, can you share a small notebook it happens in?

How are you running lines? The menu, keyboard shortcut, the editor toolbar? Does it fail in all three ways?

Does absolutely nothing happen? If something happens, what?

Dear Jonathan:

First of all, thanks for responding. The issue started around Fall Creator's Update time frame, that I am still unaware of how it happened. It's been almost a month since the update, and I haven't been able to run code in RStudio. To answer your questions:

  1. It happens on all notebooks.

  2. It fails in all three ways, menu, keyboard shortcut, and toolbar(in Run->Run selected lines), and Insert code chunk(R, SQL, Python, etc) in versions 1.1.383, 1.1.393preview. The latest 1.2.202 daily build fixed the insert button, but “run selected lines” still broken

  3. It happens regardless of R environment, I tried both Microsoft R Open 3.4.2 and R 3.4.3.

If I have to guess why it happened, it is probably character encoding, such as line break encoding(or "", or ()) in non-english Win10 Fall Creator's Update, since I use a CN version of Win10 FCR x64 for obvious language compatibility reasons beyond my control. But I am not 100% sure about that since reverting back to pre Fall Creators would be a lot of work on my workstations, and RStudio worked before the FCR update in the Chinese x64 version of win10 creators update version. The chinese version of win10 has a keyboard input (left SHIFT button that constantly switches between EN, and CN input, and if it is shifted, the space, "", and () all look the same or weird, but the encodings are changed?, that's why Counter-Strike 1.6 always crashes in win10 CN version because of the SHIFT language input button altering encodings, that US developers never had to worry about that in their code)

I am not 100% sure about this speculation.

Since I am a software developer myself, are you guys at RStudio using the latest Visual Studio 2017 with appropriate windows 10 FCR patches for compiling RStudio? Since the release of 1.1.383 is released before win10 FCR (Nov 14), I wonder if you guys are not using the latest Windows libraries for compiling code, causing incompatibilities.(Like how Tensorflow 1.4.1 can't compile under win10 FCR right now) Also look into how the daily build 1.2.202 fixed the "Insert" button to insert R, SQL, Python code chunks. It isn't working in 1.1.383, or 1.1.393preview but now works in 1.2.202

OK, I just spent a hour or so testing on both of my workstations, it is weird.

  1. Using R notebooks from, even 1.1.383 works with both insert code chunk and run selected lines. No wonder you guys aren't able to reproduce the non-response.

  2. It is definitely encoding related( I am not even using CN characters. So it's got to be space, quotes"", (), or linebreak that's causing parsing issues when the SHIFT language is involuntarily pressed. But it is totally hard to find in my own Rnotebook.)

  3. 1.1.383 and 1.1.393preview definitely both have the mentioned encoding bug. 1.2.202 is weird. It started working with insert code chunks with my own R notebook), but "run with selected lines" didn't work until Win10 FCU Patch 10.0.16299.125 two days ago.

  4. The weirdest thing is, when both my workstations got updated to win10 10.0.16299.125, running RStudio 1.2.202 daily build, run with selected lines worked on my desktop workstation, but didn't on my laptop, with the same Rnotebook! There is got to be something else in conflict, awaiting further investigation.