Rsession crashes when exiting RStudio

Simply starting and quitting RStudio produces a crash. rsession.exe.#####.dmp files created each time (found in ../AppData/Local/CrashDumps)

This topic was also disucssed in Crash when quitting

I have upgraded RStudio to the latest version v1.1.423. Problem still unresolved.

Our operating system is Windows Server 2008 R2, virtualized over XenApp 6.5. We have been using RStudio in this environment for at least 3 years. This problem has been present for about 3 months now. All users experience the same problem (approx. 10 users)

1 Like

Would you be willing to share the contents of one of these crash dumps?

Do you see the same issue with the latest daily builds of RStudio?

What would be the best way to share a crash dump?

I have not tested with the daily builds on our network environment.


How large are the files? If you have Dropbox, Google Drive, or OneDrive, I believe you should be able to upload them to these folders and then provide a download link that we could use. (You could message me the link privately if you'd prefer not to share it publicly on the community board)

Another newbie question: I would like to share privately, but I don't see any option to do that.

I'll send you a private message to get the conversation started -- you should then get a notification which will navigate you to our conversation. Thanks!

Thanks for sharing the crash dump!

Just to elaborate, are you only seeing the crash when attempting to close RStudio?

From what I can see in the crash dump, the crash is occurring when RStudio attempts to unload the libclang.dll library, which RStudio uses to provide diagnostics for C++ files opened within the RStudio IDE.

You could try disabling C++ diagnostics by setting the R option, e.g. in your ~/.Rprofile:

options(rstudio.indexCpp = FALSE)

and then restarting RStudio (it may crash once more the first time). Does that make a difference in your case?

I am seeing the crash each time I close RStudio, but users have experienced crashes at random times as well.

I tried disabling C++ diagnostics using the code snippet. Tried reopening/closing several times, but it still crashes.

I found the setting in Global Options and it was still checked. So I unchecked it and tried several times again. Still crashes.

So no, it doesn't seem to make a difference.

Hi, users at my organization are still experiencing this problem. Is anyone else having this issue?

As a long shot, does moving the folder located at:

C:\Program Files\RStudio\bin\rsclang

to somewhere else (e.g. just rename it to rsclang-backup) make a difference?

(This advice is based off of the hypothesis that the crash is occurring while attempting to unload libclang.dll; if we 'hide' it from RStudio then it will never be loaded nor unloaded)

Sorry, but yours is the first report we've heard of this issue and so we don't have a great idea as to what could be causing this.

Hi @kevinushey, this work around seems to have worked! Our RStudio sessions are no longer crashing upon exit.


1 Like

counting the same problem, it seems happened under win7.