rsession-arm64 maxes out core AFTER execution for 5+ min on M1 CPUs in macOS versions -- console is unresponsive -- REOPENED

I need to reopen this. The full description is in the post with the same title.

@technocrat Please accept my apologies for not responding earlier. No, all my R scripts behave fine when I source them via the or in an interactive terminal session. Only RStudio and in particular the session process maxes out a core. This behavior has been reported by others and diminishes the usability of the IDE. What kind of tests could I run for you? What information can I provide?

Many thanks,

Two more things come to mind:

One possibility is that RStudio is having trouble with certain features or settings on your system. For instance, some users have reported issues with RStudio's rendering engine on macOS, which can be resolved by forcing RStudio to use software rendering. As a workaround, you can try changing this with Tools -> Global Options ... -> General -> Advanced -> OS Integration -> Rendering Engine [See this post] (RStudio Mac OS X 10.15.7 Crashes Everytime).

Another potential issue could be related to RStudio's diagnostics or linting features. There have been reports of RStudio's linter causing the console to stop executing code. As a workaround, you can try disabling R diagnostics in RStudio's settings: Tools -> Global Options... -> Code -> Diagnostics [See this issue report]
(Console stops executing any code with R 4.3 underscores · Issue #13091 · rstudio/rstudio · GitHub).

Regarding my RStudio configuration: I remember to have followed some best-practice guide how to configure the IDE. The rendering engine was set to Auto-detect (recommended). I changed that to Software. I sourced my script, it ran through fine after the RStudio restart, but the console became unresponsive. And there's no auto-completion in the editor. And I cannot save any changes nor quit the application. So, this setting does not change the behavior.

My code indeed has two variables with underscores. The GitHub issue linked is closed as resolved as of May 2023. My RStudio is: Version 2023.09.1+494. I waited about 30 min to see if the process rsession-arm64 stopped maxing out a core and the IDE to become responsive again, which it did not, so I terminated the parent process RStudio. I lost unsaved changes. After opening RStudio again, I disabled Show diagnostics for R as suggested in the closed GitHub issue. This does not change anything.

Please advise. Thank you for your support.

If there is a way to skinny down your logic and data to still reproduce the behavior you could post a reprex (see the FAQ) and I can take my turn burning cycles. If that's not feasible, happy to work with you offline.

I'd like to add that in the macOS "Force quit" dialog window the RStudio app does not appear to be Not Responding like other apps are listed by macOS in similar situations. And inside RStudio I usually get a red icon indicating when the console is busy running my script which is not the case here. Most likely because the script runs through fine and only after that the rsession-arm64 process runs wild.

In one of these situations I tried to quit RStudio and it nicely asked me for saving changes which I confirmed only to get an alert some minutes later that it was unable to save my changes because it could not connect to the rsession and the next dialog window suggested that I should restart my rsession which I OK'ed. This resulted in IDE info Quitting R Session... for the next minutes until another dialog about failing to save changes appeared. OK'ing the information the RStudio process was then able to terminate itself.

I'll try to create a reprex.

Thanks again.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.