Rmd and Qmd file icons replaced with generic plain page icon.

Perhaps since upgrading MacOS 13 to 13.1, using Finder, the file icons that indicate the file type for Rmd are replaced with the generic piece of paper icon. My Qmd files have the generic piece of paper icon. I have asked Apple for help without success. I have installed the latest version RStudio and restarted the Mac. I have used the file Info window and used Open with ... and set RStudio as the application for all like files with no success. This has not connected the required icons.


The icons for .Qmd files don't show either. :unamused:

Those icons make it so much easier to scan a folder with Mac's finder.

It’s possible, within macOS to change the icon for the extension associated with the program that opens the file when invoking through Finder. That’s not something that RStudIo can help with. Extract the icon you prefer for an extension, use CMD Y to open the info pop and drag the icon over the icon shown in the upper left corner and change the extension to open the extension for all instances. I don’t recall whether case sensitivity requires both .Rmd and .rmd and .qmd and .Qmd. The convention is to use the first of each pair.

Thank you, technocrat,

I can make that work but that changes only the single file, despite setting to apply for all files of this type. And I made sure the info window was unlocked while changing. I will go back to Apple.


1 Like

Good luck. Let us all know if you find a fix.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.