RMariaDB error: Commands out of sync; you can't run this command now

I get this error when I run a simple stored procedure more than once -- but only on shinyapps.io, not when running on my local machine. The first time I call the procedure, it returns the data as expected; the second time I click the actionButton, I get the subject error.

My code:


pool <- dbPool(
  dbname = Sys.getenv("HYDROP_DBNAME"),
  host = Sys.getenv("HYDROP_HOST"),
  user = Sys.getenv("HYDROP_USER"),
  password = Sys.getenv("HYDROP_PWD")

onStop(function() {

ui <- fluidPage(
  actionButton("goBtn", "GO"),

server <- function(input, output, session) {
  observeEvent(input$goBtn, {
    query <- "CALL sp_test();"
    res <- dbGetQuery(pool, query)
    output$table <- renderTable(res)

My stored procedure definition:

    NO SQL
select * from site$$

Possibly related to this RMariaDB issue.
Edited, to add a list of the relevant versions on my local machine:

R version 4.2.1
pool 0.1.6
RMariaDB 1.2.2
DBI 1.1.3
shiny 1.7.2
RStudio 2022.07.1 Build 554

A bit more info. If I use the RMySQL driver instead, I get the same error whether on my local machine or on shinyapps:

Warning: Error in .local: could not run statement: Commands out of sync; you can't run this command now

If I use RMariaDB, I get the error when running on shinyapps, but no error when running on my local machine.