`revdep_check`: installation of one or more packages failed

I am trying to use revdep_check(num_workers = 4). However, I am getting the error below:

> revdep_check(num_workers = 4)
── INSTALL ──────────────────────────────────────────────────────────────────────── 2 versions ──
Installing CRAN version of rempsyc
also installing the dependencies ‘insight’, ‘datawizard’, ‘car’, ‘effectsize’, ‘ggsignif’

  There are binary versions available but the source versions are later:
           binary source needs_compilation
insight    0.18.4 0.18.6             FALSE
datawizard  0.6.2  0.6.3             FALSE
car         3.1-0  3.1-1             FALSE
effectsize  0.8.0  0.8.1             FALSE
ggsignif    0.6.3  0.6.4             FALSE

package ‘rempsyc’ successfully unpacked and MD5 sums checked
installing the source packages ‘insight’, ‘datawizard’, ‘car’, ‘effectsize’, ‘ggsignif’

/usr/bin/cat: insight.out: No such file or directory
/usr/bin/cat: car.out: No such file or directory
/usr/bin/cat: ggsignif.out: No such file or directory
/usr/bin/cat: datawizard.out: No such file or directory
/usr/bin/cat: effectsize.out: No such file or directory
Error in utils::install.packages(pkgs = pkgs, lib = lib, repos = myrepos,  : 
  (converted from warning) installation of one or more packages failed,
  probably ‘insight’, ‘car’, ‘ggsignif’, ‘datawizard’, ‘effectsize’

These packages are already installed locally, so I'm not sure what's the issue here. Any idea?

I did use usethis::use_revdep() beforehand. Retrying produces the same error. Session is clean after restarting. R version 4.2.1

What happens if you take the num_workers down to 1? Sometimes the parallel process can hide more informative error messages.

1 Like

revdepcheck installs all dependencies itself, into a separate library, to make the process reproducible and isolated. I don't know why these packages fail to install, but that does not seem to be a revdepcheck error, looking at it from afar....

I tried taking num_workers down to 1, and it didn’t work.

However, I suspect it might be because my package lives in my OneDrive. In particular, during revdepcheck, one of the packages (scale) was creating a bug when copying files over (permission denied). Trying to open its smallest folder to investigate led to the following error: The tag present in the reparse point buffer is invalid and it is not possible to delete the folder, even after resetting OneDrive, CHKDSK Scan, SFC Scan, etc. Really annoying. So I just moved everything GitHub out of OneDrive (since it’s already version-controlled). I know I should have done this a long time ago but didn’t have problems with it until revdepcheck.

Ok, that said, once I moved everything to its own folder out of OneDrive, I tried it again (with 1 worker again), and got the same error :frowning:

/usr/bin/cat: insight.out: No such file or directory
/usr/bin/cat: car.out: No such file or directory
/usr/bin/cat: ggsignif.out: No such file or directory
/usr/bin/cat: datawizard.out: No such file or directory
/usr/bin/cat: effectsize.out: No such file or directory

Might it have to do with these packages having different binary and source versions somehow?

sessionInfo ↓

> sessionInfo()
R version 4.2.1 (2022-06-23 ucrt)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 10 x64 (build 19044)

Matrix products: default

[1] LC_COLLATE=English_Canada.utf8  LC_CTYPE=English_Canada.utf8   
[3] LC_MONETARY=English_Canada.utf8 LC_NUMERIC=C                   
[5] LC_TIME=English_Canada.utf8    

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

loaded via a namespace (and not attached):
  [1] whoami_1.3.0           crancache_0.0.0.9001   fs_1.5.2               gmailr_1.0.1          
  [5] xopen_1.0.0            usethis_2.1.6          devtools_2.4.5         bit64_4.0.5           
  [9] progress_1.2.2         covr_3.6.1             httr_1.4.4             rprojroot_2.0.3       
 [13] tools_4.2.1            profvis_0.3.7          utf8_1.2.2             R6_2.5.1              
 [17] revdepcheck_1.0.0.9001 DBI_1.1.3              lazyeval_0.2.2         colorspace_2.0-3      
 [21] itdepends_0.0.0.9000   urlchecker_1.0.1       withr_2.5.0            tidyselect_1.2.0      
 [25] prettyunits_1.1.1      processx_3.8.0         rematch_1.0.1          bit_4.0.4             
 [29] curl_4.3.3             compiler_4.2.1         spelling_2.2           cli_3.4.1             
 [33] xml2_1.3.3             inteRgrate_1.0.20      desc_1.4.2             scales_1.2.1          
 [37] cranlike_1.0.2         callr_3.7.2            goodpractice_1.0.4     rappdirs_0.3.3        
 [41] pkgdown_2.0.6          stringr_1.4.1          digest_0.6.30          base64enc_0.1-3       
 [45] lintr_3.0.2            pkgconfig_2.0.3        htmltools_0.5.3        sessioninfo_1.2.2     
 [49] fastmap_1.1.0          htmlwidgets_1.5.4      rlang_1.0.6            rstudioapi_0.14       
 [53] RSQLite_2.2.18         shiny_1.7.3            generics_0.1.3         bootES_1.2.1          
 [57] jsonlite_1.8.3         dplyr_1.0.10           magrittr_2.0.3         Rcpp_1.0.9            
 [61] munsell_0.5.0          fansi_1.0.3            lifecycle_1.0.3        yaml_2.3.6            
 [65] stringi_1.7.8          debugme_1.1.0          pkgbuild_1.3.1         grid_4.2.1            
 [69] blob_1.2.3             promises_1.2.0.1       forcats_0.5.2          crayon_1.5.2          
 [73] miniUI_0.1.1.1         hms_1.1.2              rhub_1.1.2             checkhelper_0.0.0.9000
 [77] knitr_1.40             parsedate_1.3.1        ps_1.7.2               pillar_1.8.1          
 [81] uuid_1.1-0             boot_1.3-28            clisymbols_1.2.0       pkgload_1.3.0         
 [85] glue_1.6.2             praise_1.0.0           rex_1.2.1              remotes_2.4.2         
 [89] vctrs_0.5.0            httpuv_1.6.6           gtable_0.3.1           purrr_0.3.5           
 [93] rcmdcheck_1.4.0        rematch2_2.1.2         assertthat_0.2.1       cachem_1.0.6          
 [97] ggplot2_3.3.6          xfun_0.34              mime_0.12              xtable_1.8-4          
[101] cyclocomp_1.1.0        later_1.3.0            gargle_1.2.1           tibble_3.1.8          
[105] memoise_2.0.1          ellipsis_0.3.2         xmlparsedata_1.0.5

Can you install these packages with install.packages(), outside of revdepcheck?

Can you install these packages with install.packages() , outside of revdepcheck?

I've justed tried installing them all again with install.packages(), and they all installed successfully.

I also tried reinstalling revdepcheck with remotes::install_github("r-lib/revdepcheck") for the latest version.

[1] ‘’

Same error.

Ok, so I just waited for the latest binaries to be available for those packages and tried again, and then it worked. So maybe the binary and source versions need to match somehow. Not sure.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.