Render crashes with special character

Hello all,

I'm developping a shiny app that produced PDF based on rmarkdown::render.
The dev and deployment environments of the shiny are both on Ubuntu 18.

When I launch the shiny app via Rstudio (for development) , the generation of the PDF and the whole shiny app work fine (even with special characters in the text that is compiled to PDF).

When I generate the PDF in the deployed shiny (on a shiny-server), the render crashes (grey shiny screen in shiny) **when (and only when) ** I include special characters such as ° or €. I have not played with the locales.
I guess the problem occurs when rmardown outsources the PDF generation, because it generates the .tex file, but not the .pdf.
It does not produce errors in the logs of the app or in the app. Debugging is very tricky.

Any idea of a cause or, even better, a fix?
Thanks for your advice!


I have found the log file of the PDF compilation that fails.

It mentions th error for the special character °:

! Package inputenc Error: Unicode char ° (U+B0)
(inputenc)                not set up for use with LaTeX.

I have tried using xelatex instead pdflatex, but both fail.
Any advice ? Thx

I cannot think of anything as I do not use shiny but what happens if you just run a RMarkdown document? It might be interesting to know if it is the problem is at the basic markdown level or the shiny level.

I ran one with both ° and € with no problem . What OS? I am running Ubuntu 20.04 and I have the feeling that Linux may be more tolerant of non-ascii symbols.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.