Received HTTP/0.9 when not allowed


My problem might be a non-Rstudio-specific problem, but I only encounter this problem now in Rstudio, so I think I may get help from here.

I ran the same code last week without any issue, but now it throws the error:

Error in function (type, msg, asError = TRUE)  : 
  Received HTTP/0.9 when not allowed

I did some search and found this might be a problem in cURL. I update cURL and checked that it is configured with nghttp2.

curl --version
curl 7.81.0 (x86_64-conda-linux-gnu) libcurl/7.81.0 OpenSSL/1.1.1l zlib/1.2.11 libssh2/1.10.0 nghttp2/1.46.0
Release-Date: 2022-01-05
Protocols: dict file ftp ftps gopher gophers http https imap imaps mqtt pop3 pop3s rtsp scp sftp smb smbs smtp smtps telnet tftp 
Features: alt-svc AsynchDNS GSS-API HSTS HTTP2 HTTPS-proxy IPv6 Kerberos Largefile libz NTLM NTLM_WB SPNEGO SSL TLS-SRP UnixSockets

I don't really know what I should do for this problem. Thank you for your advice in advance.
My configuration is:

  • centOS 7
  • conda environment for R
  • Access with Rstudio Server

Hi, finally I solved it by updating RcURL package... Thanks anyway.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.