`read_csv()` can't read file

Hi
I am new as a R user and here an isue I am struggling with....any support will be welcome.

I have a 773 Mb csv file (which I can open it in Excel) but both uploading the file in the directory or using read.csv doesn't work....
See below the two attempts I did using read.csv()....

health<-read_csv("D:\data set\effectifs.csv")
Error: '\d' is an unrecognized escape in character string (:1:23)
health<-read.csv("D:\data set\effectifs.csv")
Error in file(file, "rt") : cannot open the connection
In addition: Warning message:
In file(file, "rt") :
cannot open file 'D:\data set\effectifs.csv': No such file or directory

Hi @Frantz ,

What happens if you run this?

health<-read_csv("D:\\data set\\effectifs.csv")
1 Like

Thanks for the tips, I tried it before and it didn't work, I tried to upload the file in my project and it failed too.
But today (it is annother day...) , I loaded tidyverse as usual, and the upload under my project of the file had been successfull....happy but the point is: no clue why it failed before...

False joy....
the file is uploaded but cannot have any preview....

library(readr)
effectifs <- read_csv("effectifs.csv")
View(effectifs)

the system looks to be lost....and after a while stop the R console....I openned the csv file using Excel and nothing wrong at a first glance....I am digging....

Could you share a screenshot just after running this?

library(readr)
effectifs <- read_csv("effectifs.csv")
effectifs
View(effectifs)