rClr is not getting installed in R 3.5

rClr package is not getting installed in the windows environment and R 3.5....following is the error message that we are getting...

install.packages("C:/Users/MY PC/Downloads/rClr-0.7-4.tar.gz", repos = NULL, type = "source")
Installing package into ‘C:/Users/MY PC/Documents/R/win-library/3.5’
(as ‘lib’ is unspecified)
Warning in untar2(tarfile, files, list, exdir, restore_times) :
  skipping pax global extended headers
* installing *source* package 'rClr' ...
warning: Path to the Mono SDK not found by querying the Windows registry. Mono support will be disabled
note: No VS120COMNTOOLS or VS110COMNTOOLS environment variable. Build will be made with gcc, Mono and xbuild
Created ./src/Makevars
** libs
Warning: this package has a non-empty 'configure.win' file,
so building only the main architecture

gcc -std=c++11 -I"C:/PROGRA~1/R/R-35~1.1/include" -DNDEBUG       -mms-bitfields -mwindows -I"not found/include/mono-2.0" -I"not found/include/glib-2.0" -I"not found/lib/glib-2.0/include" -D MONO_CLR -D MONO_INST   -O2 -Wall  -std=gnu99 -mtune=generic -c rClr.cpp -o rClrMono.o -lsupc++
cc1plus.exe: warning: command line option '-std=gnu99' is valid for C/ObjC but not for C++
In file included from rClr.cpp:1:0:
rClr.h:32:27: fatal error: mono/jit/jit.h: No such file or directory
 #include <mono/jit/jit.h> 
compilation terminated.
make: *** [rClrMono.o] Error 1
ERROR: compilation failed for package 'rClr'
* removing 'C:/Users/MY PC/Documents/R/win-library/3.5/rClr'
* restoring previous 'C:/Users/MY PC/Documents/R/win-library/3.5/rClr'
Warning in install.packages :
  installation of package ‘C:/Users/MYPC~1/DOWNLO~1/rClr-0.7-4.tar.gz’ had non-zero exit status

Can some one help please?

It is possible you are missing some system requirement. Please follow the instruction on the README

Also, there is windows binary available. No need to compile from source, and it is often easier to install. See the Pre compile part.

Thanks for the reply......Earlier we have successfully installed rClr for R3.4.3 version....now that we have updated the R version to R.3.5.1 we have been facing the issue since then....kindly look into the issue please...

It seems like there is an issue regarding this in the rClr repository (which looks like it hasn't been updated in some time).

Because the release of 3.5 was a major release, it is possible that the versions are somehow incompatible. However, hopefully @cderv's suggestion will work, and you can follow the pre-compile instructions successfully.

1 Like

Thanks for the reply...We have tried using the instruction as given in precompile part as suggested earlier....however the same error as mentioned above persists .

I too have this problem. Do anyone know a way around?

Did anyone figure out a way to get rClr working for R3.5+?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.