R Studio opens but no options can be selected and is non responsive

Hello everyone,

I hope someone can help me. I was using R studio just fine until a couple of hours ago. I shut it off and then restarted it and it told me the C stack was too close to the limit. I let it be and 5 minutes later, when I was going to start work on it, it is completely non-responsive. I can go through the menus but if I click on an option nothing happens. I have restarted my MacBook Pro (Monterey 12.4) with M1 Pro chip and have reinstalled RStudio (even tried to use an older version, same problem occurred). I can open R normally and it has no hitches. Any ideas would be super welcome...

Thank you,


Have you tried resetting RStudio's state?

Thank you for getting back to me.

I followed the suggestions but nothing seems to change. Whenever I open RStudio it is non-responsive and the only way to close it is via Force quit. If I try to exit following the menu there is no response. The menu options can be accessed but most are greyed out.

Any alternative suggestions? Thank you for the help.

Hi again,

I basically deleted all the files pertaining to RStudio in the Library folder, did a new install, and although initially it was blocked, after ten seconds it restarted working. Hopefully it remains that way.

Thank you @andresrcs for taking the time, I imagine it is a fairly standard behaviour on your part but to newbs like me who do not know any better it makes a huge difference to have someone help out.

All the best!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.