R studio not working for Mac apple silicon

I have tried everything to get R studio working on my mac book air M1 2020 and I just can't get it to work. I have read a lot of the other posts on this and nothing seems to help. It won't even open - when I click on it, it says R studio quit.
Any help will be greatly appreciated !

Do you have the Arm version of R installed? What version?
Do you have the Arm or X86 version of RStudio installed? What version?

I have not seen a publicly available arm version of RStudio, including the daily builds of 2022.06.0.

There is one, but it's really hard to find on the site and it's not recommended for production work as it's not yet feature complete :). In any case, can you confirm which version of RStudio and R you have installed?

I am not the OP, but I have had no problems on my 2021 MacBook Pro, starting with an arm64 version of R 4.1.1. It is currently on R 4.2.0 alpha for arm64 and RStudio 2022.06.0-daily-265.

I fixed it! I am using the Arm version - yes.
All I needed to do was go into my computer's security settings and give Rstudio access to files and folders. I'm guessing it couldn't find R without this. Then I just restarted the computer. Phew, I'm glad my new purchase isn't already proving a waste of money

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.