R studio crashing on Catalina (diagnostics attached as pdf)

Hi everyone, I'm reasonably new to R studio and I'm having issues with it crashing every time I open it. I've searched for similar reports in the community, but the only one I found had no feedback. I'm out of my depth here, so any help would be greatly appreciated.

Crash Information:

Description of crash - R studio freezes (grey screen) on opening with a message saying "R studio is taking longer than usual to load". This leads either the whole computer to crash or me to force restart. R seems to be working fine, but R studio cannot be worked in at all (including to access the preferences). I have tried uninstalling & reinstalling R and R studio, but the issue persists.

System Information:

  • RStudio Edition: Desktop

  • RStudio Version: 1.4.1106

  • OS Version: Catalina

  • R Version: R 4.0.5 (notarised)

  • Your sessionInfo():

R version 4.0.5 (2021-03-31)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS Catalina 10.15.7

Matrix products: default
BLAS: /Library/Frameworks/R.framework/Versions/4.0/Resources/lib/libRblas.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/4.0/Resources/lib/libRlapack.dylib

Random number generation:
RNG: Mersenne-Twister
Normal: Inversion
Sample: Rounding

[1] en_AU.UTF-8/en_AU.UTF-8/en_AU.UTF-8/C/en_AU.UTF-8/en_AU.UTF-8

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] compiler_4.0.5

  • RStudio diagnostics report: Uploaded as PDF

  • RStudio application log files: For me this folder is empty

From [Troubleshooting Guide: RStudio Crashed]diagnostics-report.pdf (127.0 KB)

Resetting RStudio Desktop's State seems to have worked