R shared library (/usr/local/lib64/R/lib/libR.so) not found

MAGICALLY! This is the message given back by Rstudio if I click the icon. I'm working with Ubuntu 20.04. I've found the file of interest in the ./miniconda3 directory....please help me

R shared library (/usr/local/lib64/R/lib/libR.so) not found. If this is a custom build of R, was it built with the --enable-R-shlib option?

How have you installed R and RStudio?
For RStudio to work, R needs to be compiled with the --enable-R-shlib option.

I tried your solution to that issue R shared library (/usr/local/lib/R/lib/libR.so) not found. If this is a custom build of R, was it built with the --enable-R-shlib option? but doesn't work for me. I've tried many times to re-install both but nothing changed`francesco@chiron:~$ R --version
R version 3.6.1 (2019-07-05) -- "Action of the Toes"
Copyright (C) 2019 The R Foundation for Statistical Computing
Platform: x86_64-conda_cos6-linux-gnu (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under the terms of the
GNU General Public License versions 2 or 3.
For more information about these matters see

There is no need to compile R yourself on Ubuntu 20.04, simply follow the official installation instructions from CRAN and reinstall R, the binary available on the repository is compiled with the required options.


I've tried also with that one, but Rstudio doesn't work, same error as the beginning. .. I've tried to delete everything concerning R and Rstudio from my computer but when check the version with R --version I found the 3.6.1 don't know why. After installing from CRAN the latest version, the command still gives back 3.6.1 version

Uninstall the old R version, if you have set the CRAN repository correctly, when you reinstall, you should be getting R 4.1.2 not 3.6.1

This is most likely a configuration issue with your specific system rather than an R or RStudio related problem.

Ok, probably I've uninstall it unproperly because it doesn't work. please give me the lines for the best uninstall procedure and for the new version I'll follow the CRAN instruction

I think the above is the giveaway - I guess you installed R via conda as well. Maybe you either can deactivate your conda environment or remove R altogether from the conda env. Once you do that, your likelihood of success will be much higher.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.