R session unresponsive when creating new project or opening existing project

Greetings RStudio Community,

I have been searching for resolution to in issue I am experiencing following a recent windows update that I have been unable to resolve.

Any attempt to open a project or create a new R project from RStudio fail to connect to the new R session and any actions cause RStudio to become unresponsive. Actions outside of a project and outside of RStudio all appear to work as expected. I am not using .Rdata files with any of these projects and the windows firewall is disabled on this system.

Thus far i have tried resetting the RStudio-Desktop config, resetting .rhistory and .rprofile, updating and reinstalling R and Rstudio, all with no effect. The log files do not seem to contain any errors or additional information and the only windows level event logging that I see is a generic application hang event for RStudio:

"The program rstudio.exe version 1.1.453.0 stopped interacting with Windows and was closed."

Any additional thoughts or solutions would be greatly appreciated.

RStudio diagnostic report:

[1] "1.1.453"

[1] "C:\PROGRA~1\MICROS~2\ROPEN~1\R-35~1.0\bin\x64\R.exe"

[1] ""

[1] ""

[1] "C:\MINICO~1\Library\MINGW-~1\bin\gcc.exe"

[1] "C:\PROGRA~1\Git\cmd\git.exe"

[1] "C:\PROGRA~1\VISUAL~1\bin\svn.exe"

R version 3.5.0 (2018-04-23)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows Server >= 2012 x64 (build 9200)

Matrix products: default

[1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United States.1252 LC_MONETARY=English_United States.1252 LC_NUMERIC=C
[5] LC_TIME=English_United States.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

other attached packages:
[1] RevoUtils_11.0.0 RevoUtilsMath_11.0.0

loaded via a namespace (and not attached):
[1] compiler_3.5.0 tools_3.5.0

sysname release version nodename machine login user effective_user
"Windows" "Server >= 2012 x64" "build 9200" "NODE01" "x86-64" "[USER]" "[USER]" "[USER]"

R Version:
platform x86_64-w64-mingw32
arch x86_64
os mingw32
system x86_64, mingw32
major 3
minor 5.0
year 2018
month 04
day 23
svn rev 74626
language R
version.string R version 3.5.0 (2018-04-23)
nickname Joy in Playing
[1] "C:\ProgramData"

[1] "C:\Users\[USER]\AppData\Roaming"

[1] "1"

[1] "NODE011836"

[1] "C:\Program Files\Common Files"

[1] "C:\Program Files (x86)\Common Files"

[1] "C:\Program Files\Common Files"

[1] "NODE01"

[1] "C:\Windows\system32\cmd.exe"

[1] ":0"

[1] "NO"

[1] "-1"

[1] "-1"

[1] "//[ORGANIZATION].org/[NETWORK]/home/L/[USER]/Documents"

[1] "H:"

[1] "\"

[1] "\\[ORGANIZATION].org\[NETOWRK]\home\L\[USER]"

[1] "C:\Progra~1\Java\jre1.8.0_77"

[1] "C:\Users\[USER]\AppData\Local"

[1] "\\NODE0001"

[1] "R_ARCH"

[1] "32"

[1] "Windows_NT"

[1] "C:\Program Files\Microsoft\R Open\R-3.5.0\bin\x64;C:\Program Files\Teradata\Client\16.10\bin;C:\Program Files (x86)\Teradata\Client\16.10\bin;C:\Program Files\swigwin-3.0.12;C:\Miniconda3;C:\Miniconda3\Library\mingw-w64\bin;C:\Miniconda3\Library\usr\bin;C:\Miniconda3\Library\bin;C:\Miniconda3\Scripts;C:\ProgramData\Oracle\product\12.1.0\dbhome_1\bin;C:\RBuildTools\3.3\bin;C:\RBuildTools\3.3\gcc-4.6.3\bin;C:\ProgramData\Oracle\Java\javapath;C:\Program Files\Java\jdk1.8.0_45\bin;c:\Rtools\bin;c:\Rtools\gcc-4.6.3\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Altaro\Altaro Hyper-V Backup\;C:\Program Files\Microsoft\Web Platform Installer\;C:\Program Files\VisualSVN Server\bin;C:\Program Files\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files\RRO\R-3.2.0\bin\x64;R.exe;C:\Julia-0.3.11\bin;C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\;C:\Program Files (x86)\CMake\bin;C:\Windows\Microsoft.NET\Framework64\v4.0.30319;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Java\jdk1.8.0_45\jre\bin\server;C:\Program Files (x86)\nodejs\;C:Windows\system32;C:\Program Files\\Hewlett-Packard\HPSUT\bin;C:\Program Files\MIT\Kerberos\bin;C:\Miniconda3\share\py4j;C:\Apache\apache-maven-3.5.2\bin;C:\Program Files\Git\cmd"


[1] "AMD64"

[1] "Intel64 Family 6 Model 45 Stepping 7, GenuineIntel"

[1] "6"

[1] "2d07"

[1] "C:\ProgramData"

[1] "C:\Program Files"

[1] "C:\Program Files (x86)"

[1] "C:\Program Files"

[1] "C:\Windows\system32\WindowsPowerShell\v1.0\Modules\;C:\Program Files\Microsoft Security Client\MpProvider\"

[1] "C:\Users\Public"

[1] "C:\anaconda3;$SPARK_HOME/python"

[1] "/x64"

[1] "gcc 4.9.3"

[1] "C:/PROGRA~1/MICROS~2/ROPEN~1/R-35~1.0/doc"

[1] "C:/PROGRA~1/MICROS~2/ROPEN~1/R-35~1.0"

[1] "C:/Users/[USER]/AppData/Local/RRO/library;C:/Program Files/RRO/R-3.2.0/library"

[1] "H:/Documents/.Rprofile"

[1] "//[ORGANIZATION].org/[NETWORK]/home/[USER]/Documents"

[1] "C:/Program Files/RStudio/resources/mathjax-26"

[1] "\\.\pipe\43569-rsession"

[1] "C:/Program Files/RStudio/bin/rpostback"

[1] "63341846741"

[1] "1"

[1] "256"

[1] "80"

[1] "C:/Program Files/RStudio/bin/msys-ssh-1000-18"

[1] "C:/Program Files/RStudio/bin/pandoc"

[1] "43569"

[1] "[USER]"

[1] "C:/Program Files/RStudio/bin/winutils"

[1] "RDP-Tcp#21"

[1] "C:"

[1] "C:\Windows"

[1] "C:\Users\[USER]\AppData\Local\Temp\2"

[1] "xterm-256color"

[1] "C:\Users\[USER]\AppData\Local\Temp\2"




[1] "[USER]"

[1] "C:\Users\[USER]"

[1] "C:\Program Files\Oracle\VirtualBox\"

[1] "C:\Program Files\VisualSVN Server\"

[1] "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\Tools\"

[1] "C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\Tools\"

[1] "C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\Tools\"

[1] "C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools\"

[1] "C:\Windows"

[1] "C:\Apache\cluster_config\"

[1] ".GlobalEnv" "tools:rstudio" "package:RevoUtils" "package:stats" "package:graphics" "package:grDevices" "package:utils"
[8] "package:datasets" "package:RevoUtilsMath" "package:methods" "Autoloads" "package:base"
Log file: rdesktop.log

Log file: rsession-[USER].log

1 Like

During the hang, is it the underlying R session that is frozen, or had the whole IDE frozen as well? Are you still able to take some actions within the IDE (e.g. type in the editor) or is the whole thing frozen?

Does it make a difference if you use a CRAN build of R as opposed to the MRO build of R? We've also seen in some rare cases that having conflicting programs on the PATH can interfere with RStudio's operation; does removing some of the entries you have on the PATH make a difference?

Good afternoon Kevin,

Thanks for the response. I have actually made some progress on this issue, although i'm not sure I entirely understand why. To start by answering some of your questions:

At first it is just the R session that is un-responsive, but performing any actions cause all of RStudio to hang. I have tried with both CRAN and MRO versions of R ranging from 3.2 to 3.5 with no success.

The system has 2 local drives, a C: and an E: drive, with the E drive being version controlled. I actually tested this morning using my user space on the C: drive, and had no issues. I then went back and disabled version control for my projects on the E: drive and my projects worked again.

Uncertain why having version control on for projects caused this issue and I would like to use version control in the future for my projects, but at-least i now have a somewhat valid work around.

Looking forward to if anyone has any thoughts on what aspects of using Git or SVN might contribute to this. Thanks for the reply Kevin, I was going mad trying to think of additional things to try.

There was an issue recently identified on Windows where RStudio could get stuck in a loop querying the version control state of a project (for projects using Git for version control), but this should be fixed in the latest RStudio release (v1.1.453).

Just to confirm, are you using Git for version control, or another VCS? Is there by any chance anything else unique about this project? If you execute e.g.

git status

from the command line for these projects, does that command execute without issue?

If all else fails, you might try the preview release of RStudio to see if things are any better there as well.

1 Like