R Session Aborted

I'm using HistDAWass package and running WH_hclust function, then R crushes, below a screenshot, and a message "Start New Session" rise.

I tried to reinstall and using different versions of R.

Could you please help.

There are many reasons something like this can happen. For example, last time it happened to me was when there was a bug in one of the packages dealing with parallel computing.

Does this function fails on all data or some specific data? Can you try to make it as a reprex (reproducible example), so that anyone can run some code on his/her machine to see if it's something with your machine or a bug in a package.


One way to start narrowing it down would be to try running it in R (outside of RStudio), and seeing if that makes a difference.

Hi Misha,
I had tried it with other sets of data and all my packages, as well as the R (3.4.4), R-studio (Version 1.1.423), are updated.

Thank you

Hi Mara,

The similar result happens, the software crashed, please see the screenshot.

Thank you,

That means it's unlikely it's a problem with RStudio itself (since it's also a problem in R). So I'm going to move this out of the IDE category.

I don't know the HistDAWass package, but, given how specific this is, you might have more luck on StackOverflow.

Either way, though, you'll need some sort of a reproducible example. Since your code is crashing, you won't be able to make a full reprex (short for minimal reproducible example). However, the code for loading the library, a small sample of the input data, etc. will go a long way towards helping us help you.

1 Like

A post was split to a new topic: R session crashes with Rgtk2::demo(alphaSlider)