R session aborted Python never runs

Hi All,

I hope everyone is well. I have a quick query and would like support. When ever I create a new Python script in R Studio Version 1.4.1103, R version 3.5.3 (2019-03-11) -- "Great Truth".

I get the following message: R encountered a fatal error. The session was terminated.
I am not able to run any Python scripts or commands at all

Can any one offer any help or assistance? Does this have anything to do with the reticulate package?

Thanks in advance.

Do you mean that R errors, rather than opening a new blank script in the script editing pane ?

Yes, thats correct. In fairness I think it is an internal error with R studio, having said that no further information is provided. When I R studio just for R its typically rock solid and hardly ever crashes.

I created a new Python script and did a question test printing "hello world" like literally:
print("Hello world").

Running simple math operations results in the same error.

Please see image attached.


(ps I am happy to do a screen recording if that helps?)

I would guess its a reticulated problem.
What happens if rather than Rstudio you use Rgui?

I haven't tried using Python with Rgui and I generally had difficulties installing it in the past.
I guess it would make sense to check most stable version of recticulate and move to that version?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.