R session aborted, encountered a fatal error when combining large rds files


I want to combine 3 large RDS files into one. Each time I run the code, my Rsession aborts and I get the error message that R encountered a fatal error.

I already tried to clear my global environment and updated all the packages, but it didn't help.

My session info:
R version 4.0.3 (2020-10-10)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS Big Sur 10.16

Matrix products: default
LAPACK: /Library/Frameworks/R.framework/Versions/4.0/Resources/lib/libRlapack.dylib

[1] de_DE.UTF-8/de_DE.UTF-8/de_DE.UTF-8/C/de_DE.UTF-8/de_DE.UTF-8

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] compiler_4.0.3 magrittr_2.0.1 Matrix_1.3-4 tools_4.0.3 fastmatch_1.1-3 Rcpp_1.0.7
[7] tinytex_0.34 stringi_1.7.5 grid_4.0.3 quanteda_3.1.0 xfun_0.27 stopwords_2.3
[13] RcppParallel_5.1.4 lattice_0.20-45

The code I want to run:


rds_alle_tweets <- (list.files(pattern = "*.rds", full.names = TRUE))
    .x = rds_alle_tweets,
    .f = ~read_rds(.x) %>% mutate_all(as.character))

Did someone encounter a similar problem or has a fix for it?

Thanks in advance! :slight_smile:

How large are the files and how much RAM is available to your system?

2 files which are around 100 MB and one file which is around 280 MB, so not even that big.

I have a 2 GHz Dual-Core Intel Core i5 processor and 8 GB 1867 MHz LPDDR3.

I am also getting R Session Aborted. No detectable pattern to it. But not using RDS.
I don't know how to begin to troubleshoot but happy to run any diagnostics that people recommend.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.