R Notebook issue running Trelliscopejs

RStudio Community

I am exploring the trelliscopejs package in R Notebook and having problems rendering the graphs. The graphs render in RStudio IDE but when I knit the Notebook I receive an error.

title: "R Notebook"
    df_print: paged

# libraries

gapminder_sub <- gapminder %>%
  filter(country == "Australia" | country == "New Zealand")

# ------------------------

# part 1

# Create the plot
ggplot(gapminder_sub, aes(year, lifeExp)) +
  geom_line() +
  # Facet on country and continent
  facet_trelliscope(~ country + continent )

kniting this code results in .....

Line 18 Error in path.expand(path) : invalide 'path' argument calls: <Anonymous> ... same_path - 
               > normalize_path -> normalizePath -> path.expand



1 Like

This is an error from trelliscopejs :package: .

This is what I get if I run rmarkdown::render() in console then look at the traceback for the error

Error in path.expand(path) : invalid 'path' argument
  1. rmarkdown::render("test.Rmd")
  2. knitr::knit(knit_input, knit_output, envir = envir, quiet = quiet)
  3. knitr:::process_file(text, output)
  6. knitr:::process_group.block(group)
  7. knitr:::call_block(x)
  8. knitr:::block_exec(params)
  9. knitr:::eng_r(options)
 11. knitr:::evaluate(...)
 12. evaluate::evaluate(...)
 13. evaluate:::evaluate_call(...)
 17. knitr:::value_fun(ev$value, ev$visible)
 18. knitr:::fun(x, options = options)
 21. trelliscopejs:::knit_print.facet_trelliscope(x, ...)
 22. trelliscopejs:::print.facet_trelliscope(x)
 23. trelliscopejs:::resolve_app_params(...)
 24. trelliscopejs:::is_abs_path(orig_path)
 25. trelliscopejs:::same_path(x, file.path(".", x))
 26. trelliscopejs:::normalize_path(p1, ...)
 27. base::normalizePath(x, winslash = winslash, mustWork = must_work)
 28. base::path.expand(path)

It seems like an issue in trelliscopejs - you should open an issue there:

@ reichmaj, were you able to resolve the issue? Did you find a solution? I am getting the same error while knitting a Rmarkdown with trelliscope inside. I checked trelliscopejs issue pages for if you have raised the issue as per @ cderv suggestion, but could not find any.. Thank you.

No I'm still receiving the same error. I did send an email off to Ryan Hafen, from the package but haven't heard anything.

Ok. Thanks. I too put a post and tweeted him. Hope to hear soon.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.