R-Markdown - Not showing output inline when saved


When I create my R-Markdown file in R-Studio, when I run the chunk it displays the output inline; https://i.imgur.com/Y45Dcw8.png

However, immediately when I save the file and give it a ''name'', it stops showing the output. I have tried adding the

chunk_output_type: inline

at the top, however this doesn't work either. What am I doing wrong?

For example, writing this does not create any output: https://i.imgur.com/xTkV7jV.png
However, when plotting something, e.g when using ggplot, it does appear inline. It is just some of the output that is missing inline.

Kind regards.

It is possible renaming the file will invalidate the cache, which is used in inline output mode. Does this also happens if you don't rename the file, and just save ?

Yes, it does still happen if I dont rename.

Then I don't know.

I'll move to the RStudio IDE category as this is really someting with the IDE and not rmarkdown directly.

You could try with another file and if you can reproduce each time, you could open an issue in the Github RStudio IDE repo

Okay. It happens to me every time I save the file. I will try to post it there.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.