R Graphics: Device 2 (ACTIVE)

RStudio is outputting graphics to a pop-up window entitled "R Graphics: Device 2 (Active)" and not placing anything in the RStudio plots pane. I found other people with this problem in old posts, but no solution.

As you might have already read, RStudio creates its own graphics device.
Could you restart RStudio, and try this in a fresh RStudio session:


You should see this:

[1] "RStudioGD"

I'm curious if you could give a screenshot of the odd popup window as well.
Is this with all uses of plot? or specific to some code you can offer as a reprex?


I tried for the screenshot, but new users cannot attach documents.
It was with plot() and hist().

This was the best help, because it helped me find the problem.
gave me a huge output, but at the end was a warning that RStudio will not work with R graphics drivers 12. Please update RStudio.

The problem was fixed after installing the RStudio update.

Thank you.



Could you mark this as your solution (FAQ: How do I mark a solution?).

This will bump you to "level-1" and so you should be able to post images now.

And your solution taught me a little lesson about helping folks here and on other communities. When you wrote "I found other people with this problem in old posts, but no solution", I assumed you had seen the same posts I had linked to "R Graphics: Device 2 (ACTIVE)", in which some people had updated RStudio and resolved the issue.
I therefore didn't suggest the idea. But we probably should have started there.

1 Like

Interestingly I have just updated to the latest RStudio (v99.9.9) and R (v 3.5.2) and I have the same problem as above. I am using OpenSuse Linux for it, and I am getting the following warning when I type

Warning message:
R graphics engine version 12 is not supported by this version of RStudio. The Plots tab will be disabled until a newer version of RStudio is installed.

1 Like

It's certainly not the latest version. The latest stable version is 1.1.463.

That version is what you get when you compile rstudio from source using this option -DCMAKE_BUILD_TYPE=Debug and is equivalent to the latest daily build

1 Like

Thank you both. Unfortunately that version does not install in my machine (OpenSuse Leap 42.3). Judging from the error that throws it is because it requires boost version greater than 1.63, while the one in the repositories in my case is 1.54.
UPDATE: I have discovered a dependencies directory that comes with the code and may solve the issue as it installs boosts. I am giving it a try.

Here, do you mean v99.9.9 as That version?

I thought version numbers of daily builds are 1.2.x or 1.3.x. I've never used any daily build or compiled from source, though.

Yes, you get version 99.9.9 when you compile rstudio from source with -DCMAKE_BUILD_TYPE=Debug, it's equivalent to the latest daily build at the moment of compiling, but not exactly the same because you don't usually know exactly what commits are included on any given build that they release.

And BTW if you are not on a production environment or doing some serious work, give 1.2.X version a try, it has a lot of new and cool features.

1 Like

I´m trying to customize plot background.
I´ve added


to "RProfile.site" file. It opens an undesired device window.
I´ve tried


It shuts the window, but loses the par(bg='seashell').
How can I set this parameter?