R encountered a fatal error. The session was terminated

after update of R to 3.4.4 and Rstudio after running it I am having the above error seen on other posts but can't fix mine.

Sorry to hear you're having trouble! Can you try the prescriptions outlined in:

and let us know if any of those help

I follow these posts but problem remains

Another option is to uninstall and reinstall R and RStudio.

If you'd like, I'll help you pass on your issue to the open source folks, they'll want your error information:

  • General description
  • The output of RStudio.Version()
  • Error messages
  • Log files (See here, -
    assuming you can get to it)
  • Crash Report (See here)
  • Attempted steps taken to fix
  • Have you successfully launched RStudio in the past?

Thank you, yes Rstudio was working fine. I think it is relared to R (quite strange) after update to R 3.4.4 as I had 3.4.3 working. I tried both still not working and then installed 3.3.3 and it is working. I stayed on this R version up to now and avoid to update it unless I have a fix.

I experienced a similar problem after upgrading from R 3.5.3 to R 3.6.0. What fixed the problem was to remove code using options(error) from my .R profile.

Thanks to @noamross for pointing to this issue.