R diagnostics doesn't show up in Mac version

I use RStudio Version 1.2.1335 on a Mac (macOS Mojave 10.14.5).
Error message (R diagnostics) doesn't show up almost at all.
For example, nothing happens when I input...
It just ignores it.
Of course, I have already checked the Preferences, and I think it is set properly.
Can anyone help me with this?

Hi, @eieona, and welcome. I have the same set up as yours, and both RStudio and the R IDE return the same error message

> 5 = 10
Error in 5 = 10 : invalid (do_set) left-hand side to assignment

I have Preferences | Code | Diagnostics check for the first two boxes.

It seems unlikely that the underlying R version would affect that, but just for completeness what version are you using? I'm on 3.6.1

Hi, @technocrat, thank you for your quick response.

By R version is 3.6.1.

My R does return the same error message as yours, but not RStudio.
I will attach a screenshot (new users could upload only one at a time


Well, THAT is truly weird. Do you preferences look like the attachment?

1 Like

I changed my setting like your attachment and it finally resolved!! I deeply appreciate your kind and perfect advice.

Great! Please mark this as a solution. Not for me, but for others who have the same issue.

Be sure to come back whenever you have other R/RStudio questions!

It's also possible that there was a sink active -- for example, if the code you had just ran executed:


That would cause any output that would normally be output to the console to instead be diverted to a file. If you run into this issue again, you could try:


to close an active sink.


Along the same lines, I noticed in your screenshot that you seem to have been using Rcmdr earlier in your session.

When run from RStudio, Rcmdr is supposed to send its output to RStudio's R console (see: Getting Started With the R Commander, p.27, footnote 25), but I wonder if something could also have gone wrong there?

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.