R commander, problemens with installation

A bit of a long story, but after using R -studio + R commander for some time it stopped working, i can still open it but a lot of the functions is disappeared.

When reinstalling all of the program (many times) i got the error message, that Rtools is missing:

Is there somebody who can tell me what i should do to make it work again ?

Hi @Christina1,
Welcome to the RStudio Community Forum.

It looks like Rtools is missing from your machine. You can download the correct version from your local CRAN mirror site under "R binaries" > "windows". Once Rtools is fixed you can then reinstall the Rcommander packages.


Also, if you have updated RStudio or R commander lately, be aware that they are no longer compatible so your best choice would be to launch R commander from the R GUI instead.

thanks, i have tried that too

So where should i find that under install packages?? or where else? :slight_smile:

Hi @Christina1,
That means using your browser to go to the main CRAN website (https://cran.r-project.org/, or your local CRAN mirror site in your country) and navigating to the Rtools download section as described in my first reply. Download and install Rtools (note that R, Rcommander, and RStudio are not involved in this process). Then restart R GUI, then Rcommander.


okey, well i have tried that, but it seems installing it on the pc isn't enough?

Okey, i tried one more time with Rtools and now the error looks like this

Those are "information" messages, not error messages. It looks like Rcmdr has started completely correctly. Do you now see the RCommander window pop up over the R Gui window? If so, everything is OK and you are ready to begin programming in R.

It does start but without all the graphs functions and three functions in "manage variabels in active datasite"

Dear @Christina1,
I think its time for you to do some serious home-work: reading about how Rcommander works! You need to load a dataset before those menu items are available to use.
At the prompt in R Gui type help("Rcmdr")

It is after loading a dataset, and they are still missing, but yes i am new in the r program

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.