R and RStudio crashes running read_parquet() on Mac M1

As the title states, both R and RStudio crash with a 'fatal error' when I try to run


For reference, read_parquet() is a function from the arrow() library

Using: Macbook Pro M1 2020 R version 4.1.0 RStudio 1.3.1093

1 Like

I am facing the same issue!

I tried installing arrow and try the function but don't get your fatal error. That being said, I don't have .parquet file so it just told me that I don't have the file.

If you tell me how I can create a .parquet file, I wouldn't mind trying on my end and see if it works.

You are on Mac M1? Can you try read_csv_arrow("file.csv") with some csv file. If that works then it should be fine.
For me none work. However when I publish R shiny app on shinyapps.io, it works. But not working on my local machine (Mac M1).


Yes, I am on M1 Mac Mini, with XCode installed, and R 4.1.0 for M1. Unfortunately, I also got fatal error. So I guess the issue is probably hardware related.

If you use R for M1 Arm, it might worth checking if it would work with R for Intel. If that still doesn't work, I think you probably need to find another hardware.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.