Quarto using wrong Jupyter interpreter

I recently installed Julia, and now documents won't render because packages are missing. I ran quarto check jupyter in the in-built Terminal in RStudio, and it leads to .julia/conda/3/bin/python3, so that's the problem. I've been able to change it for a specific project with a QUARTO_PYTHON environment variable, but I was hoping to do it for everything. The documentation says that Quarto checks which version of Python is on PATH, but I can't figure that out -- running which jupyter in the Terminal shows the version of Python I expect. (And quarto check jupyter in the Terminal shows the same version as which python. This seems to be a Quarto issue -- the Python version in Project/Global Options is also what I expect.

I'm on Mac Monterey, if that makes a difference.

I tried again to with the Global Python options in RStudio, and now I did get it to work. I must have selected a conda environment that didn't have jupyter notebook installed on it, so it defaulted to the Julia environment (not sure why that was). But now it's working without an environment file.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.