Quarto render ERROR: NotFound: The system cannot find the path specified. (os error 3)

Hello all!
I've been trying to use Quarto as my thesis writing method but I ran into some problems very early on.
I wanted to use Quarto project feature since I have some experience with R projects within Rstudio, but when trying to render the output (or create a project) I got several errors.

I'm running RStudio 2022.07.1 Build 554, R version 4.2.1 (2022-06-23 ucrt), on a windows 10 Home Version 21H2 laptop, with OneDrive and Boxcryptor. Previous experience with RStudio were flawless. I created projects, worked on them, rendered RMarkdown notebooks to Word files, etc. I tried many many things to try to solve the problem, including installing, re-installing R, Rstudio and Quarto CLI. In the end, after fearing that I really screwed up the many paths, I decided to fresh install windows. (I had it coming anyways).

The following situations and problems were recreated after the fresh install (formated disk, completely new windows installation with a windows usb installation disk created about a month ago), with Boxcryptor and OneDrive both turned on and off.

After many many tries, I found that of the two OneDrive folders, only one causes problems. (filepath= D:\OneDrive - myuniversity.edu)

The problems:
Situation 1:
New Quarto project created on desktop works like a charm. Folders and files are created correctly, and when rendering (after installing prompted needed packages) I am able to render both to HTML and Word documents.

Situation 2:
If I move that newly created Quarto folder to a OneDrive on another disk (path indicated above) I get 'ERROR: NotFound: The system cannot find the path specified. (os error 3)'

Situation 3:
Additionally, when trying to create a new quarto project on that folder, I get ''C:/Program' is not recognized as an internal or external command, operable program or batch file.' Some files and folders are created but don't work. When creating a Quarto project on the other OneDrive, no problems are encountered.

Situation 4:
I can create a normal RStudio project on the conflicting folder, and render output normally, even .qmd files.

Ok, I hope this sums it up. I have been trying to solve this for longer that I would like. For the time being I'm going to use a normal RStudio project. It's a pity Quarto project feature is not working though, since I liked the idea of the global yml options. Also, hopefully my experience will help the devs sort some issues.

platform x86_64-w64-mingw32
arch x86_64
os mingw32
crt ucrt
system x86_64, mingw32
major 4
minor 2.1
year 2022
month 06
day 23
svn rev 82513
language R
version.string R version 4.2.1 (2022-06-23 ucrt)
nickname Funny-Looking Kid

Sorry you had a bad experience so fat. I believe you encountered several limitation, some of which should be fixed in latest version of tools.

We still have issues with the same report:

Maybe you case is among one of the still opened one. We have some issues with network drive that still needs to be solved.

This is a RStudio issue

and maybe more. This unfortunately happen when Quarto is installed somewhere with a space in path. Hopefully next RStudio version will fix this.

You can try install Quarto as user mode (unless you have a space in your username), or move the system installation in a place without space. Sorry for that.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.