Quarto options not in RStudio IDE

Quarto is working, kind of. I can load the library and render the hello.qmd file I got from the quarto website without a problem. But I have no options to create new Quarto files or projects in the IDE. I don't see any configuration settings in Tools->Global Options. I can create the files manually as long as they render, but still...

In my googling I did see some similar reports, but they all seemed old/resolved, and didn't help. At least one seemed a problem specific to Fedora, which I use, but that was pretty old and seemed to be problems with installing quarto, but it's installed fine.

I'm using the 2023.12.1 Build 402 of the IDE on Fedora 39. Quarto version is 1.4.552.

Thanks in advance for any help.

Brian

Just do
File -> Quarto Document

Save the file with a .qmd extension. Eample "mywork.qmd".

The problem is that there is no File -> Quarto Document in my menu.

It will render if I save as qmd, but the qmd-style commands/options are ignored.

I am not sure of your meaning here. Are you say that a command to create a .qmd is not there or that commands within the file are not working?

For example if I changed my YAML from

format: html

to

format: pdf

that command is not working?

I just mean that previews, visual mode editing, html output, all ignore the qm syntax and I have to use the {r, options} syntax.

Maybe a more fruitful question might be what YAML would be generated if I did have the option to generate a new Quarto document or project? What is the skeleton?

If you are just using the basic template it lookks like this:

---
title: "Untitled"
format: html
editor: visual
---

## Quarto

Quarto enables you to weave together content and executable code into a finished document. To learn more about Quarto see <https://quarto.org>.

## Running Code

When you click the **Render** button a document will be generated that includes both content and the output of embedded code. You can embed code like this:

```{r}
1 + 1

You can add options to executable code like this

#| echo: false
2 * 2

The echo: false option disables the printing of code (only output is displayed).

Here is an example of a working Quarto document.


title: "Example"
author: "jrkrideau"
date: today
format: pdf

#| label: setup
#| include: false

library(tidyverse)
library(flextable)
#| label: data
#| include: false
DT <- data.frame(aa = 1:10, bb = 10:1)


Introduction

#| tbl-cap: First Table
#| label: first_table
#| echo: false

tb1 <- flextable(DT)
tb1

Thank you. So if I render this in R Studio it ignores the qm commands but otherwise renders the output "normally". If I use quarto preview in my cli it renders properly, respecting the quarto commands.

So I need to make RStudio aware of the quarto installation somehow I think. How do I do that? The executable is in the standard /usr/bin location.

Thanks for all your help.