Quarto keeps trying to run my code blocks using python

I cant' get quarto to consistently not use python to run my code blocks. Sometime is does and sometime it doesn't but this is just a listing, I don't want RStudio to try to find a python program when I knit.

Just this code chunk will result in knitr trying to find python even though eval is false.

#| eval: false

#| eval: false

condition_COVID_index_columns = [
demoAug = (
    .join(condition_index,                        on = ['personid'], how = 'inner')
    .join(measurement_index,                      on = ['personid'], how = 'left')
    .join(medication_index,                       on = ['personid'], how = 'left')
          .select(condition_COVID_index_columns), on = ['personid'], how = 'left')
    .join(order_list_medication_compliance,       on = ['personid'], how = 'left')
    .join(procedure_CRC_index,                    on = ['personid'], how = 'left')
    .join(event_CRC_index,                        on = ['personid'], how = 'left')

Did you see https://quarto.org/docs/computations/execution-options.html#unexecuted-blocks ?
Maybe that helps?

Thanks, I did see that but at some point I was able to to cut and paste the entire document into a new document and have it run OK. So it must have retained previous setting in a buffer somewhere.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.