QtWebEngineProcess and RStudio are taking over my CPU

Rather suddenly yesterday, I ceased to be able to do anything within RMarkdown in RStudio. A check of the Activity Monitor on my MacBook Pro (running macOS Monterey 12.5.1) shows the QtWebEngineProcess taking >100% of my CPU whenever I try to do anything within an R Markdown document. Merely opening an RMarkdown document in RStudio or trying to create a new one causes QtWebEngineProcess to jump to ~130% CPU and the cursor to become non-functional. A search of the R Studio shows that this issue recurs regularly, but the topics seem to be closed at 21 days without resolution. I have also done a lot of Googling and tried the various suggestions with no success.

Even clicking on About RStudio or Preferences freezes everything. After a long delay, I could see that I am running RStudio 2022.07.1 Build 554 on my Mac. (My R version is 4.2.1.). Each time RMarkdown unfreezes and I try to execute a code block, QtWebEngineProcess takes over my CPU and RMarkdown freezes.

Based on suggestions I have read here and elsewhere, I have tried the following fixes, none of which worked:

  • I switched the Rendering engine to Software (This seemed to make the issue even worse, so I went back to the default.)
  • I moved the file I was last working on to a new location and turned off the "Restore most recently opened project at startup" option thinking that maybe the file I was last working on was triggering the problem. (This didn't help.)

I don't know what to try next. Any suggestions would be appreciated!!

The next version of RStudio won't use QtWebEngine at all. I would recommend trying a daily build from here:


If you don't want to use daily builds, we also have a 2022.07 build that doesn't use QtWebEngine. You can get that here (scroll to "Desktop Electron"):

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.