Professional Driver Application_Intent = ReadOnly

We have the following situation:

  • RHEL7
  • RStudio Workbench 1.4.1717-3, "Juliet Rose"
  • Professional Driver 1.8.0 (
  • MS SQL Server 2016 Always On Cluster
    Server 1: Primary node
    Server 2: Secondary node readonly
    Server 3: Listener
  • Odbcinst.ini on RStudio Server
    Driver = /opt/rstudio-drivers-1.8.0/sqlserver/bin/lib/
    RStudio_Version = 1.8.0
    Version =
    Installer = RStudio Pro Drivers
  • Odbc.ini:
    Driver = SQLServer
    Server = Listener
    Application_Intent = ReadOnly
    Database = Rstudio_readonly_test
    Port = 1433
    UID = xxxxx
    PWD = xxxxx

We have several sql databases that we can access with professional driver, no problem at all .

But now, we want connect directly to the readonly node by using the parameter “application_intent = readonly”, unfortunately that does not work.

Connect to the Listener/primary node (without application_intent): OK

Connect directly to the primary node: OK

Connect directly to the secondary node: OK

Primary and secondary DB can change the Server, that's why we need the parameter “application_intent”

RStudio Documentation:

Do you have any advice on how to solve this problem?

Thanks very much

Reto Iten

Which error message do you get when you use Application_Intent = ReadOnly in the DSN?

Testing in the linux console with isql: no error message is given. The cursor flashes until ctrl-C is pressed.


I have created a support ticket at RStudio. They didn't find any errors either and passed the problem on to the driver vendor.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.