Problems with pushing to GitHub on RStudio cloud

I'm running RStudio Cloud. I'm authenticated, or at least I think I am, I can pull okay, but when I run git push I get this:

rstudio-user@application-1341760-deployment-4078074-5kv2n:/cloud/project$ git push
warning: push.default is unset; its implicit value has changed in
Git 2.0 from 'matching' to 'simple'. To squelch this message
and maintain the traditional behavior, use:

  git config --global push.default matching

To squelch this message and adopt the new behavior now, use:

  git config --global push.default simple

When push.default is set to 'matching', git will push local branches
to the remote branches that already exist with the same name.

Since Git 2.0, Git defaults to the more conservative 'simple'
behavior, which only pushes the current branch to the corresponding
remote branch that 'git pull' uses to update the current branch.

See 'git help config' and search for 'push.default' for further information.
(the 'simple' mode was introduced in Git 1.7.11. Use the similar mode
'current' instead of 'simple' if you sometimes use older versions of Git)

error: cannot run rpostback-askpass: No such file or directory

I tried to set the default push behaviour but that doesn't work either, same error message

error: cannot run rpostback-askpass: No such file or directory

Thanks for reporting this. I tracked down this issue which sounds related. I will ask around internally to see if there is a workaround.

1 Like

Sorry, I just noticed that this is not tagged as RStudio cloud. Sorry! You may have noticed that from the terminal contents anyway but just in case you hadn't I thought I should point it out.

I have now discovered that changing from https to ssh fixes the issue.

It looks like this has been fixed, and should be made available during the next release cycle.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.