Problems with loading 'rgdal' library after RStudio Cloud Maintenance on 7/25

Hi there,

Following the scheduled RStudio Cloud maintenance yesterday (7/25) afternoon, I am now unable to load the 'rgdal' library in any of my projects (existing or new). Output included below.

I tried uninstalling and reinstalling the package, but the same error was encountered.

Any help would be much appreciated!

> install.packages("rgdal")
Installing package into ‘/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.6’
(as ‘lib’ is unspecified)
also installing the dependency ‘sp’

trying URL 'http://package-proxy/src/contrib/sp_1.3-1.tar.gz'
Content type 'application/x-tar' length 1895329 bytes (1.8 MB)
downloaded 1.8 MB

trying URL 'http://package-proxy/src/contrib/rgdal_1.4-4.tar.gz'
Content type 'application/x-tar' length 2209713 bytes (2.1 MB)
downloaded 2.1 MB

* installing *binary* package ‘sp’ ...
* DONE (sp)
* installing *binary* package ‘rgdal’ ...
* DONE (rgdal)

The downloaded source packages are in
> library(rgdal)
Loading required package: sp
**Error: package or namespace load failed for ‘rgdal’ in dyn.load(file, DLLpath = DLLpath, ...):**
** unable to load shared object '/home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.6/rgdal/libs/':**
**  /home/rstudio-user/R/x86_64-pc-linux-gnu-library/3.6/rgdal/libs/ undefined symbol: _ZN10OGRFeature11SetGeometryEP11OGRGeometry**

I think that the maintenance is correlated, not causal.
My guess is that this is due to Rcpp being released yesterday.
We will investigate further, thank you for reporting this.

The cause of the issue was an update to our base image that picked up a change in the gdal system binaries which was not compatible with our cached binaries of the rgdal package.

The cached binaries were purged and will be built as they are requested. I have tested with R 3.6.0 and it seems good.

Please try again.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.