Problems with loading any package

Error: package or namespace load failed for ‘mlr’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):

namespace ‘pkgconfig’ 2.0.1 is already loaded, but >= 2.0.2 is required

Whenever I am trying to install any package, it shows it has been successfully installed. However, when I try to load it, it shows the above error. And hence, when I try to use the relevant function, it shows "the function is not found". And this has been the case with all the packages.

I tried reloading the packages, updating those as well. However, nothing worked. -

System Information:

  • RStudio Edition: 3.4.3 (2017-11-30)
  • RStudio Version: 3.4.3 (2017-11-30)
  • OS Version: Windows 10
  • R Version: 1.1.423

It would be great if you could help me understand this issue. Just t let you know, it was working fine few days back.Many thanks

From Troubleshooting Guide: Using RStudio

1 Like

Try updating pkgconfig with install.packages("pkgconfig").

I'm assuming you've switched your R and RStudio versions here, or you'd be working from a very old R version (current is 3.6). You can check from inside R with R.version.

1 Like


it worked. Many thanks.

I tried the R.version as well and here are the details.

platform x86_64-w64-mingw32
arch x86_64
os mingw32
system x86_64, mingw32
major 3
minor 4.3
year 2017
month 11
day 30
svn rev 73796
language R
version.string R version 3.4.3 (2017-11-30)

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.