Problems with installing Rcmdr in MAC OS Catalina

Hi, I´m new to R, and I'm having problems installing Rcmdr. I've downloaded R4.0.0 as well as XQuarts and tools of (R Commander Installation). written by John Fox, but i´m getting this error message I don´t understand:

trying URL ''
Content type 'application/x-gzip' length 5128740 bytes (4.9 MB)
downloaded 4.9 MB

tar: Failed to set default locale

The downloaded binary packages are in

What does it mean?

I also tried installing the library after the step described above, but then I'm getting this message instead:

Loading required package: splines
Loading required package: RcmdrMisc
Loading required package: car
Loading required package: carData
Error: package or namespace load failed for 'car' in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
there is no package called 'vctrs'
Error: package 'car' could not be loaded.

I would be very grateful if you could help me. Thanks!

Have you tried installing the missing dependency?


I have tried installing with the command you suggest me and this is the result:

There is a binary version available but the source version is later:
binary source needs_compilation
vctrs 0.2.4 0.3.0 TRUE

Do you want to install from sources the package which needs compilation? (Yes/no/cancel) y

The source package is correctly installed but there are several warnings

During startup - Warning messages:
1: Setting LC_CTYPE failed, using "C"
2: Setting LC_TIME failed, using "C"
3: Setting LC_MESSAGES failed, using "C"
4: Setting LC_MONETARY failed, using "C"

  • installing source package 'vctrs' ...
    ** package 'vctrs' successfully unpacked and MD5 sums checked
    ** using staged installation
    ** libs
    xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
    ERROR: compilation failed for package 'vctrs'
  • removing '/Library/Frameworks/R.framework/Versions/4.0/Resources/library/vctrs'

The downloaded source packages are in
Warning message:
In install.packages("vctrs") :
installation of package 'vctrs' had non-zero exit status

I have a MAC Os Catalina 10.15.4 and I have installed R 4.0.0. I have done almost everything, but I´m not an expert. I will be thankful if you help me to install R commander

The easiest solution would be to answer "no" to this question, you would get a precompiled binary version that is a little older but much easier to install.
If you want to install the latest version from source, then you need to install Xcode in your system (not in R) and the recommended development tools for macOS systems.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.