problems with getting the new R version

Hi guys i need urgent help pleaseeee!!

I have Ubuntu debian 20.04.4 and installed R studio. But i have the version R 3.6.4. and it says that this is the newest version but thats not true, the new version is something with 4... I removed rbase and rstudio from terminal and reinstall but it is still the same.

Please help me!!!

First you should update R:
then you can update Rstudio: Download the RStudio IDE - RStudio

when i try to update R this error appears

Try to add --allow-unauthenticated

its still the same :frowning: :(((((

i mean i dont understand why do i get the version of 2020. i removed rbase and rstudio than i reinstalled it but still old version

It seems you haven't added the gpg key correctly, have you followed the installation instructions?

sudo apt update -qq
# install two helper packages we need
sudo apt install --no-install-recommends software-properties-common dirmngr
# add the signing key (by Michael Rutter) for these repos
# To verify key, run gpg --show-keys /etc/apt/trusted.gpg.d/cran_ubuntu_key.asc 
# Fingerprint: E298A3A825C0D65DFD57CBB651716619E084DAB9
wget -qO- | sudo tee -a /etc/apt/trusted.gpg.d/cran_ubuntu_key.asc
# add the R 4.0 repo from CRAN -- adjust 'focal' to 'groovy' or 'bionic' as needed
sudo add-apt-repository "deb $(lsb_release -cs)-cran40/"

hi thanks for answering so fast, but i cant even update now, when i am typing "sudo apt update -qq" i get. I am really new to linux/ubuntu so i could need every help

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.