Problems with enconding on Oracle

Hello World,

We are facing an issue reading characters on an Oracle 11g database, we realized that in some local R installations the software reads the real enconding ( in our case its WE8MSWIN1252 similar to Latin1 but with more characters) showing us the spanish characters but on others pc installations its not reading the charaters even if its configured as es_ES.UTF-8

We did a new installation on clean centos 7 installled on spanish and we face the same issue. Anye clue of what files should we modify to read on the database character set?

Best Regards
Thanks In advance

Hi, what R packages are you using to connect to the database? Also, are you passing an encoding argument as part of the connection string?

Hi Edgar,

we use ROracle 1.3-1 we tried on linux and windows platform with the same result.

we also tried to set up the Sys.setlocale("LC_ALL", "ES_ES.UTF-8") without success.

we tried to set up the local linux variable and restart the R service ( export NLS_LANG=SPANISH_SPAIN.WE8MSWIN1252 on the .bash_profile) also no success.

Finally we tried to change the os lang with this command on centos: system-config-language --text also without success.

Which are the main config files for the language ?

Thanks in advance

Hi there!

Did you find out something Edgar?

Thanks in advance

Hi again,

Any clue or doc to follow?


Sorry not at this time.