Problems importing dataset

Hi guys, I'm very new to R programming, sorry if my question is trivial, but I am having problems to import the dataset by selecting "From text (readr)". I cannot access the data.

I am using the latest version for R and RStudio, at Windows 7

This is what I get after importing the data:

unable to open 'C:Users/AndrÃ/Documents/R/win-library/4.0/rlang/R/rlang.rdb': No such file or directory

I couldn't fix this problem till now, if someone can help I will appreciate, thank you all!

1 Like

Hi @andre_macedo and welcome!

It looks like the error you're seeing is not necessarily related to the data import. I would suggest reinstalling the rlang package and seeing if that fixes the error. To do that, first restart RStudio and then run:


Hopefully that fixes the problem, and if not, you can post any error messages you receive here.

1 Like

This could also be a problem with the non ASCII characters in your windows user name, R has problems with that very often. I would recommend changing your user name or installing into the system level package library to avoid this kind of issues.

1 Like

Hey guys, thanks for the reply
I already done reinsatlled the package a few times
And then I get the message that said "Rtools is required to build R packages but is not currently installed..."
But down this message it sains 'rlang' successfully unpacked...

Already changed my user name too, I looked at this answer for another issue, here at this forum and for that guy it worked, but not for me..

Well, that's it

Have you got a different error message after the user name change? If you still get the same error message then the change has not being successful, also, have you tried simply installing into the system level package library?

The user name didn't change!
And sorry man, but what you mean by "installing into the system level package library"?
I tried trought the console and manually

R has two default locations for the package library, one is the user level library (where you were trying to install) and the other one is the system level library located at the installation folder, usually looks like this.

install.packages("rlang", lib = "C:\\Program Files\\R\\R-4.0.0\\library") 

Just did it and still didn't work man...

Gonna try to porperly change my user name...

This is not very informative, it would be better if you post the current error message you are getting.

I get "Error: unexpected input in "install.packages("rlang", lib = C.....)"
I copy the exact path in the folder..

You have to be more specific, what is the exact command you are using?, it seems you are passing the lib parameter incorrectly.

I used exactly this command

install.packages("rlang", lib = "C:\Program Files\R\R-4.0.0\library")

This - "C:\Program Files\R\R-4.0.0\library" - is the exact path

I was checkinh that some people had problems with using the latest versions of R and RStudio at Windows 7, couldn't be it maybe?

You have to use a normalized path (with double slash) otherwise the single slash is interpreted as an scape character.

This shouldent be an issue as long as you are using a 64-bit version

It appointed the same error:

Error: unexpected input in "install.packages("rlang", lib = C:\Program Files\R\R-4.0.0\library")

I am going to reinstall it again...R an RStudio again..damm

You've got to either use double backslashes \\ or forward slashes / for the path as explained by andresrcs above. Re-installing R & RStudio won't help you.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.