Problem with shiny server : Error in loadNamespace(name) : there is no package called ‘shiny’

Hi all,

I have a problem with shiny server, I can't access my applications, I have "The application failed to start. The application exited during initialization.". So, I went to see the last log, and I saw:

"Error in loadNamespace(name) : there is no package called ‘shiny’
Calls: local ... tryCatch -> tryCatchList -> tryCatchOne ->
Execution halted"

When I stop shiny server and then start it, I have one log per application, the mine but also the hello-shiny app, and I get this error for all the apps ... I don't undestand because it works last week ... I don't know what has changed.

Here my configuration file of shiny server :

 # Instruct Shiny Server to run applications as the user "shiny"
 run_as shiny;
 preserve_logs true;
 # Define a server that listens on port 3838
 server {
   listen 3838;
   # Define a location at the base URL
   location / {
     # Host the directory of Shiny Apps stored in this directory
     site_dir /srv/shiny-server;
     # Log all Shiny output to files in this directory
     log_dir /var/log/shiny-server;
     # When a user visits the base URL rather than a particular application,
     # an index of the applications available in this directory will be shown.
     directory_index on;
     app_idle_timeout 1500;

Shiny is well installed in /apps/R-3.5.0/lib64/R/library/. I even installed shiny dev version from rstudio's github, to be sure, but i have the same error.

I run shiny server as shiny user, so, I made sure that this user has the right on the R packages and he sees them well, no problems on that side.

If I run R, then start my shiny application, as root or shiny, it works perfectly, with this command:


So, shiny server don't find the shiny package and I don't know why ... Have you an idea about that ?

Thank you very much,