Problem with rlang version and tidyverse and ggmap


since a couple of days, RStudio is not able to load the packages tiduverse and ggmap. I obtain the following error message:

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
namespace ‘rlang’ 0.4.2 is already loaded, but >= 0.4.5 is required

Although I have tried to restart the R session, update and re-install all three packages. I don't know what to do. I haven't changed anything (as far as I know).

Thanks in advance.

You have rlang version 0.4.2 installed and loaded, and that prevent the use of tidyverse that requires 0.4.5 here.

Can you check the rlang version of your installed package ? In the package Pane or using packageVersion("rlang") ?
you can also find where it is installed with find.package("rlang")

install.packages("rlang") should have updated the package. Did the installation worked ?

Thanks for your quick response.
The installation of rlang did not work:

package ‘rlang’ successfully unpacked and MD5 sums checked
Warning in install.packages :
cannot remove prior installation of package ‘rlang’

The installed version was:
[1] ‘0.4.2’
And it is in this R library
[1] "C:/Users/mrom8073/Documents/R/win-library/3.6/rlang"

I deleted the file from the library and installed it again (I am not sure I should do it like that... with the risk of deleting things I shouldn't... but it worked!)

Thank you so much!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.