Problem with codegeno/Synbreed

I am facing a problem with codeGeno, package Synbreed. I am trying to impute a snp dataset 188x92716. The genotypes are “0/0” (homozygous for the reference allele), “0/1” (heterozygote), and “1/1”, but the problem also occurs after coding to 0, 1, and 2 (integer). When I run

datac<-codeGeno(datagp, label.het=“0/1”)#datagp is a correct gpdata object, including map and genotype

I get an error message. The same error occurs run

datac<-codeGeno(datagp, label.het=1)

I tried a function

Is.het=function(x=datagp) {substr(x,1,1) != substr(x,3,3) }


Datac<-codeGeno(datagp, label.het=is.het)

But it does not work too.

The instructions provided by Synbreed does not work for the example datasets cattle and mice, where there are heterozygotes. It is annoying. I will appreciate any information. Regards,

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.