Problem to deploy Golem to shinyapps

Dear community i have a problem,
I am trying to re-deploy an application that is already online.

When i have tried to deploy the app by using the blue development button, the system had suggested that I upgrade all the packages, which of course I did.

I noticed that the process of deploying shinyapps has changed, and in fact it gives me the following error

── Preparing for deployment ────────────────────────────────────────────────────
✔ Re-deploying "OrganicFarmingMap" to "server: / username: agronomofiorentini"
ℹ Looking up application with id "9365113"...
✔ Found application <>
ℹ Bundling 30 files: '.here', '.Rbuildignore', '.Renviron', 'app.R', 'data/lista_soilorganiccarbon.csv', 'DESCRIPTION', 'dev/01_start.R', 'dev/02_dev.R', 'dev/03_deploy.R', 'dev/run_dev.R', 'inst/app/www/favicon.ico', 'inst/golem-config.yml', 'man/run_app.Rd', 'NAMESPACE', 'report/report_immagini_satellitari.Rmd', 'tests/testthat/test-mod_new_request.R', 'tests/testthat/test-mod_old_request.R', 'tests/testthat/test-mod_summary.R', …, 'R/mod_user_setting.R', and 'R/run_app.R'
ℹ Capturing R dependencies with renv
The following package(s) were installed from an unknown source:
- OrganicFarmingMap []
renv may be unable to restore these packages in the future.
Consider reinstalling these packages from a known source (e.g. CRAN).

Traceback (most recent calls last):
9: rsconnect::deployApp(appDir = "C:/Users/Utente/Desktop/OrganicFarmingMap", 
       appFileManifest = "C:/Users/Utente/AppData/Local/Temp/a5e3-395e-e662-2338", 
       account = "agronomofiorentini", server = "", 
       appName = "OrganicFarmingMap", appId = 9365113, launch.browser = function(url) {
           message("Deployment completed: ", url)
       }, lint = FALSE, metadata = list(asMultiple = FALSE, asStatic = FALSE))
8: bundleApp(appName = target$appName, appDir = appDir, appFiles = appFiles, 
       appMetadata = appMetadata, quiet = quiet, verbose = verbose, 
       pythonConfig = pythonConfig, image = image)
7: createAppManifest(appDir = bundleDir, appMetadata = appMetadata, 
       users = users, pythonConfig = pythonConfig, retainPackratDirectory = TRUE, 
       image = image, verbose = verbose, quiet = quiet)
6: bundlePackages(bundleDir = appDir, extraPackages = extraPackages, 
       verbose = verbose, quiet = quiet)
5: computePackageDependencies(bundleDir, extraPackages, quiet = quiet, 
       verbose = verbose)
4: snapshotRenvDependencies(bundleDir, extraPackages, verbose = verbose)
3: renv::snapshot(bundleDir, packages = deps$Package, prompt = FALSE)
2: renv_snapshot_validate_report(valid, prompt, force)
1: stop("aborting snapshot due to pre-flight validation failure")
Errore in renv_snapshot_validate_report(valid, prompt, force) : 
  aborting snapshot due to pre-flight validation failure
Chiamate: <Anonymous> ... snapshotRenvDependencies -> <Anonymous> -> renv_snapshot_validate_report
Esecuzione interrotta

Consider that I am using golem to develop this application, would you please let me know what I am doing wrong?

Solved here [BUG] Problem to deploy golem app to · Issue #1098 · ThinkR-open/golem · GitHub

@fiorepalombina Thanks for Sharing, really appreciated .... I always preferred to get help from the Github But i'm unable to find this link...

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.