Problem loading tidyverse library

(I work with Windows, and RStudio. Both RStudio and R are updated as of today)

I installed the tidyverse package (install.packages("tidyverse")) but when I want to load it (library(tidyverse)) I get an error saying that some package is missing, a new one every time. I have tried installing those packages one by one but I am on the 5th one now and keep getting a new, similar error saying that a new package isn´t installed. So far: ‘plyr’, ‘psych’, ‘gtable’, ‘reshape2’, ‘scales’... in that order... I quit trying at this point thinking that there must be some kind of problem.

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
there is no package called ‘scales’

I have searched other questions here but have not found a helpful answer so far. Any hint?

After reading a few more posts, I seem to have fixed my problem by updating all packages and selecting a theme (which was null before). Not sure which of the two did the trick, but library(tidyverse) now loads without an error...

Welcome! I'm glad you sorted out your problem (and thanks for marking a solution :grinning:).

It was most likely the package update that fixed it — being a sort of metapackage for a bunch of other packages, each of which has its own (sometimes extensive) dependency tree, tidyverse has a lot of dependencies that need to be installed. If something goes wrong during the installation of one of the dependencies, it can cancel the installation of that branch — but with lots of install messages flying by, it can be hard to notice that this happened.