problem installing sjPlot

Hi there, I'm using RStudio and trying to install sjPlot to plot effect sizes. I've installed sjPlot withthe usual install.packages() command, nevertheless when I try to load it, this is what happens:

Error: package or namespace load failed for ‘sjPlot’ in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
namespace ‘tibble’ 2.1.3 is already loaded, but >= 3.0.0 is required
In addition: Warning message:
package ‘sjPlot’ was built under R version 3.6.3

So, I thought that my tibble version was too old, therefore I tried to upload it, I first did:


I tried to inspect tibble package using the "installed.packages" command.

Package LibPath Version Priority Depends Imports LinkingTo Suggests Enhances License License_is_FOSS
License_restricts_use OS_type Archs MD5sum NeedsCompilation Built

I tried to install once again sjPlot doing install.packages() command and also: install.packages("sjPlot", repos = "")

Then I tried to install once again tibble:

install.packages("tibble", repos = "")
Error in install.packages : Updating loaded packages

Restarting R session...

Loading required package: ROCR
install.packages("tibble", repos = "")
Error in install.packages : Updating loaded packages
install.packages("tibble", repos = "")

And when I try once again:

Installing package into ‘C:/Users/glori/OneDrive/Documenti/R/win-library/3.6’
(as ‘lib’ is unspecified)
trying URL ''
Content type 'application/zip' length 411838 bytes (402 KB)
downloaded 402 KB

package ‘tibble’ successfully unpacked and MD5 sums checked
Warning in install.packages :
cannot remove prior installation of package ‘tibble’
Warning in install.packages :
problem copying C:\Users\glori\OneDrive\Documenti\R\win-library\3.6\00LOCK\tibble\libs\x64\tibble.dll to C:\Users\glori\OneDrive\Documenti\R\win-library\3.6\tibble\libs\x64\tibble.dll: Permission denied
Warning in install.packages :
restored ‘tibble’

The downloaded binary packages are in

Still nothing changed, and I get the same error when I try to load sjPlot usign library() command.

Do you have any suggestion to solve the issue?

Thank you kindly!

I think you need to redo your step in a clean R session, with no project open and not other RStudio window open

You can use RGui also to be sure. Then install tibble again, and retry SjPlot.

From the errors messages, your session seems to have some packages already loaded. On windows, if a dll is loaded, you can't install the package that is loaded.

Hope it helps


Thank you kindly! May I ask you a further question? I've trued to close and restart RStudio, however every time I restart it, I'm back to the same workspace/project

[workspace loaded from ~/.RData]

(and the same happens when RStudio tries to restart the session to upload the package). How can I avoid this? Thank you

You should configure the IDE to never save Rdata file on exit, and do not restore Rdata file on startup.

I personally never use a .RData file to be sure to be most often in a blank state when I start.


1 Like

Thank you kindly for your help, that worked.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.