Problem installing packages from github

Hey I've been trying to install package developer versions from github without any success. When I try remotes::install_github("tidyverse/dplyr")ordevtools::install_github("tidyverse/dplyr") I get:

Downloading GitHub repo tidyverse/dplyr@HEAD
Error in utils::download.file(url, path, method = method, quiet = quiet,  : 
  cannot open URL ''

Even try pak::pak("tidyverse/dplyr") and get:

→ Will update 1 package.
→ Will download 1 package with unknown size.
+ dplyr 1.0.10 → [bld][cmp][dl] (GitHub: 94df8bf)
? Do you want to continue (Y/n) y
ℹ Getting 1 pkg with unknown size
✖ Failed to download dplyr (source)          
✖ Failed to download 1 package.                                     
! error in pak subprocess
Caused by error: 
! Failed to download dplyr from ``.
Type .Last.error to see the more details.

And when decided download the zip to install it manually:

My OS is windows 10, I am using RStudio version 2022.12.0-353 and R version 4.2.2 (2022-10-31 ucrt) -- "Innocent and Trusting". I am guessing that something isn't working properly on my side, so I would like to know if anyone has faced a similar problem lately and know any solution.

Could be network condition. Test with https, which works from SEA US at 2023-01-29 10:25 PST

Solved it is an issue with my internet supplier and the router I am using, change network and worked as normal

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.