problem installing package MESS

I am getting the following error output when I try to install the R package MESS. My desktop is on a University protected remote desktop, and the two aliases in the address of my personal library apparently refer to the physical storage device and my account name. But this library address, which translates to "c:\Users\hunsickerl\Documents\Home\R\win-library\4.0" works for installing and loading libraries.
Note, however, that the error seems to result from the fact that the two includes in the call to the mingw32 command omit the initial "R" of "c:/Recycle..." . It is not surprising, then, that the system can't find the files at the incorrect file address.
This exact problem actually occurred yesterday when I tried to upgrade five files before the compiled versions were added to CRAN last night. So I suspect that this is not a problem with the source MESS package, but something that happens when I try to install from source.
Any suggestions? Thanks in advance. Larry Hunsicker

> install.packages('MESS')
Installing package into ‘C:/$Recycle.Bin/S-1-5-21-1343024091-1383384898-725345543-277224/$RNTH3XX/Documents/Home/R/win-library/4.0’
(as ‘lib’ is unspecified)

  There is a binary version available but the source version is later:
     binary source needs_compilation
MESS  0.5.6  0.5.7              TRUE

installing the source package ‘MESS’

trying URL ''
Content type 'application/x-gzip' length 2879450 bytes (2.7 MB)
downloaded 2.7 MB

* installing *source* package 'MESS' ...
** package 'MESS' successfully unpacked and MD5 sums checked
** using staged installation
** libs

*** arch - i386
"c:/Users/hunsickerl/Documents/R/Rtools40/mingw32/bin/"g++ -std=gnu++11  -I"C:/PROGRA~1/R/R-40~1.2/include" -DNDEBUG  -I'C:/ecycle.Bin/S-1-5-21-1343024091-1383384898-725345543-277224/NTH3XX/Documents/Home/R/win-library/4.0/Rcpp/include' -I'C:/ecycle.Bin/S-1-5-21-1343024091-1383384898-725345543-277224/NTH3XX/Documents/Home/R/win-library/4.0/RcppArmadillo/include'        -O2 -Wall  -mfpmath=sse -msse2 -mstackrealign -c RcppExports.cpp -o RcppExports.o
RcppExports.cpp:4:10: fatal error: RcppArmadillo.h: No such file or directory
 #include <RcppArmadillo.h>
compilation terminated.
make: *** [C:/PROGRA~1/R/R-40~1.2/etc/i386/Makeconf:229: RcppExports.o] Error 1
ERROR: compilation failed for package 'MESS'
* removing 'C:/$Recycle.Bin/S-1-5-21-1343024091-1383384898-725345543-277224/$RNTH3XX/Documents/Home/R/win-library/4.0/MESS'
* restoring previous 'C:/$Recycle.Bin/S-1-5-21-1343024091-1383384898-725345543-277224/$RNTH3XX/Documents/Home/R/win-library/4.0/MESS'
Warning in install.packages :
  installation of package ‘MESS’ had non-zero exit status

Update: Problem fixed, though not solved. I rebooted the remote desktop, and the weird directory went away. I was then able to install MESS with no problem. First approach to an error that makes no sense: Reboot. Thanks to anyone that considered my problem.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.